%global _empty_manifest_terminate_build 0
Name: python-auditorium
Version: 20.2.1
Release: 1
Summary: A Python-powered slideshow maker with steroids.
License: MIT
URL: https://pypi.org/project/auditorium/
Source0: https://mirrors.aliyun.com/pypi/web/packages/5b/a7/00cfa1712bf0b23dfe061cc55d3dda3888ad24348d8b6affcfbef2450ea3/auditorium-20.2.1.tar.gz
BuildArch: noarch
Requires: python3-markdown
Requires: python3-fire
Requires: python3-jinja2
Requires: python3-pygments
Requires: python3-fastapi
Requires: python3-aiofiles
Requires: python3-websockets
Requires: python3-uvicorn
%description
# Auditorium
[
](https://github.com/apiad/auditorium/blob/master/LICENSE)
[
](https://pypi.org/project/auditorium/)
[
](https://pypi.org/project/auditorium/)
[
](https://travis-ci.org/apiad/auditorium)
[
](https://codecov.io/gh/apiad/auditorium)
[
](https://gitter.im/auditorium-slides/community)
[
](https://auditorium-demo.apiad.net)
> A Python-powered slideshow creator with steroids.
See the demo at [auditorium-demo.apiad.net](https://auditorium-demo.apiad.net).
## What's this about
Auditorium is a Python-powered slideshow generator.
You write pure Python code, and obtain an HTML+JavaScript slideshow (using the amazing [reveal.js](https://revealjs.com) library).
The awesomeness comes from the fact that your Python backend is connected to the slideshow frontend, which allows your slideshow to dynamically change according to user input or automatically.
This opens the door to a few interesting use cases:
* The slides content itself can be generated by code. For example, long and repetitive sets of slides can be automatically generated, or tables and graphs embedded in slides can be generated on-the-fly with `matplotlib`, `bokeh`, `altair`, `plotly`, or any visualization package that produces HTML output.
* You can insert components in the slides that respond to user input, and execute a Python code in response. For example, you can generate an interactive graph that can be modified by moving sliders in a slideshow.
* You can create beautiful animations with simple Python code, that automatically play on a slide, using visualization libraries or simple HTML markup.
> **And all of this without writing a single line of HTML or JavaScript.**
Alternatively, if you need little to no Python code, you can author your slideshow in pure Markdown and add some Python sprinkless here and there when necessary.
## Installation
Simply run:
pip install auditorium[server]
To see a quick demo run:
auditorium demo
And point your browser at [localhost:6789](http://localhost:6789).
## Quick Start and Tutorials
If you want to quickly grok `auditorium`, the best option is to [look at the demo online](https://auditorium-demo.apiad.net) and then
[read the source code](https://github.com/apiad/auditorium/blob/master/auditorium/demo.py). This way you will both see the end result and what effort it takes to get there.
* [Authoring a slideshow with Python](https://apiad.net/auditorium/quickstart/#python-first)
* [Authoring a slideshow with Markdown](https://apiad.net/auditorium/quickstart/#markdown-first)
* [Rendering a slideshow as purely static HTML](https://apiad.net/auditorium/quickstart/#going-full-static)
* [Hosting a slideshow online for free](https://apiad.net/auditorium/hosting/#hosting-freely-with-auditorium-publish)
## Made with Auditorium
* [Auditorium Demo](https://auditorium-demo.apiad.net) - a slideshow showcasing the most important features from `auditorium`.
### Your Contributions Here
If you have a slideshow to showcase here, feel free to [edit this Readme](https://github.com/apiad/auditorium/edit/master/README.md) and send a pull request. Add your website, Github repository, and any other information.
If you feel like sending some support please consider adding a badge somewhere in your website or repository:
```html
```
It looks like this:
## History
See [the docs](https://apiad.net/auditorium/history).
## Collaboration and License
License is MIT, so you know the drill: fork, develop, add tests, pull request, rinse and repeat.
See collaboration details [in the docs](https://apiad.net/auditorium/contributing).
%package -n python3-auditorium
Summary: A Python-powered slideshow maker with steroids.
Provides: python-auditorium
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-auditorium
# Auditorium
[
](https://github.com/apiad/auditorium/blob/master/LICENSE)
[
](https://pypi.org/project/auditorium/)
[
](https://pypi.org/project/auditorium/)
[
](https://travis-ci.org/apiad/auditorium)
[
](https://codecov.io/gh/apiad/auditorium)
[
](https://gitter.im/auditorium-slides/community)
[
](https://auditorium-demo.apiad.net)
> A Python-powered slideshow creator with steroids.
See the demo at [auditorium-demo.apiad.net](https://auditorium-demo.apiad.net).
## What's this about
Auditorium is a Python-powered slideshow generator.
You write pure Python code, and obtain an HTML+JavaScript slideshow (using the amazing [reveal.js](https://revealjs.com) library).
The awesomeness comes from the fact that your Python backend is connected to the slideshow frontend, which allows your slideshow to dynamically change according to user input or automatically.
This opens the door to a few interesting use cases:
* The slides content itself can be generated by code. For example, long and repetitive sets of slides can be automatically generated, or tables and graphs embedded in slides can be generated on-the-fly with `matplotlib`, `bokeh`, `altair`, `plotly`, or any visualization package that produces HTML output.
* You can insert components in the slides that respond to user input, and execute a Python code in response. For example, you can generate an interactive graph that can be modified by moving sliders in a slideshow.
* You can create beautiful animations with simple Python code, that automatically play on a slide, using visualization libraries or simple HTML markup.
> **And all of this without writing a single line of HTML or JavaScript.**
Alternatively, if you need little to no Python code, you can author your slideshow in pure Markdown and add some Python sprinkless here and there when necessary.
## Installation
Simply run:
pip install auditorium[server]
To see a quick demo run:
auditorium demo
And point your browser at [localhost:6789](http://localhost:6789).
## Quick Start and Tutorials
If you want to quickly grok `auditorium`, the best option is to [look at the demo online](https://auditorium-demo.apiad.net) and then
[read the source code](https://github.com/apiad/auditorium/blob/master/auditorium/demo.py). This way you will both see the end result and what effort it takes to get there.
* [Authoring a slideshow with Python](https://apiad.net/auditorium/quickstart/#python-first)
* [Authoring a slideshow with Markdown](https://apiad.net/auditorium/quickstart/#markdown-first)
* [Rendering a slideshow as purely static HTML](https://apiad.net/auditorium/quickstart/#going-full-static)
* [Hosting a slideshow online for free](https://apiad.net/auditorium/hosting/#hosting-freely-with-auditorium-publish)
## Made with Auditorium
* [Auditorium Demo](https://auditorium-demo.apiad.net) - a slideshow showcasing the most important features from `auditorium`.
### Your Contributions Here
If you have a slideshow to showcase here, feel free to [edit this Readme](https://github.com/apiad/auditorium/edit/master/README.md) and send a pull request. Add your website, Github repository, and any other information.
If you feel like sending some support please consider adding a badge somewhere in your website or repository:
```html
```
It looks like this:
## History
See [the docs](https://apiad.net/auditorium/history).
## Collaboration and License
License is MIT, so you know the drill: fork, develop, add tests, pull request, rinse and repeat.
See collaboration details [in the docs](https://apiad.net/auditorium/contributing).
%package help
Summary: Development documents and examples for auditorium
Provides: python3-auditorium-doc
%description help
# Auditorium
[
](https://github.com/apiad/auditorium/blob/master/LICENSE)
[
](https://pypi.org/project/auditorium/)
[
](https://pypi.org/project/auditorium/)
[
](https://travis-ci.org/apiad/auditorium)
[
](https://codecov.io/gh/apiad/auditorium)
[
](https://gitter.im/auditorium-slides/community)
[
](https://auditorium-demo.apiad.net)
> A Python-powered slideshow creator with steroids.
See the demo at [auditorium-demo.apiad.net](https://auditorium-demo.apiad.net).
## What's this about
Auditorium is a Python-powered slideshow generator.
You write pure Python code, and obtain an HTML+JavaScript slideshow (using the amazing [reveal.js](https://revealjs.com) library).
The awesomeness comes from the fact that your Python backend is connected to the slideshow frontend, which allows your slideshow to dynamically change according to user input or automatically.
This opens the door to a few interesting use cases:
* The slides content itself can be generated by code. For example, long and repetitive sets of slides can be automatically generated, or tables and graphs embedded in slides can be generated on-the-fly with `matplotlib`, `bokeh`, `altair`, `plotly`, or any visualization package that produces HTML output.
* You can insert components in the slides that respond to user input, and execute a Python code in response. For example, you can generate an interactive graph that can be modified by moving sliders in a slideshow.
* You can create beautiful animations with simple Python code, that automatically play on a slide, using visualization libraries or simple HTML markup.
> **And all of this without writing a single line of HTML or JavaScript.**
Alternatively, if you need little to no Python code, you can author your slideshow in pure Markdown and add some Python sprinkless here and there when necessary.
## Installation
Simply run:
pip install auditorium[server]
To see a quick demo run:
auditorium demo
And point your browser at [localhost:6789](http://localhost:6789).
## Quick Start and Tutorials
If you want to quickly grok `auditorium`, the best option is to [look at the demo online](https://auditorium-demo.apiad.net) and then
[read the source code](https://github.com/apiad/auditorium/blob/master/auditorium/demo.py). This way you will both see the end result and what effort it takes to get there.
* [Authoring a slideshow with Python](https://apiad.net/auditorium/quickstart/#python-first)
* [Authoring a slideshow with Markdown](https://apiad.net/auditorium/quickstart/#markdown-first)
* [Rendering a slideshow as purely static HTML](https://apiad.net/auditorium/quickstart/#going-full-static)
* [Hosting a slideshow online for free](https://apiad.net/auditorium/hosting/#hosting-freely-with-auditorium-publish)
## Made with Auditorium
* [Auditorium Demo](https://auditorium-demo.apiad.net) - a slideshow showcasing the most important features from `auditorium`.
### Your Contributions Here
If you have a slideshow to showcase here, feel free to [edit this Readme](https://github.com/apiad/auditorium/edit/master/README.md) and send a pull request. Add your website, Github repository, and any other information.
If you feel like sending some support please consider adding a badge somewhere in your website or repository:
```html
```
It looks like this:
## History
See [the docs](https://apiad.net/auditorium/history).
## Collaboration and License
License is MIT, so you know the drill: fork, develop, add tests, pull request, rinse and repeat.
See collaboration details [in the docs](https://apiad.net/auditorium/contributing).
%prep
%autosetup -n auditorium-20.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-auditorium -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 20.2.1-1
- Package Spec generated