%global _empty_manifest_terminate_build 0
Name:		python-blah
Version:	0.1.12
Release:	1
Summary:	Thin wrapper around source control systems
License:	UNKNOWN
URL:		http://github.com/mwilliamson/blah
Source0:	https://mirrors.aliyun.com/pypi/web/packages/99/06/b1196a40ee3125f6471f0ad0b672fcdc6315f2051f33f805e74765e90b4e/blah-0.1.12.tar.gz
BuildArch:	noarch


%description
**This package is deprecated.** Blah has been renamed to `Mayo <https://pypi.python.org/pypi/mayo>`_. Please use the package ``mayo`` instead.
The main use of Blah is being able to download repositories from a URI
that specifies what version control system (VCS) is being used:
    import blah
    blah.fetch("git+https://github.com/mwilliamson/blah.git", "/tmp/blah")
    print open("/tmp/blah/README.md").read()
Blah can also be used as a script:
    blah fetch git+https://github.com/mwilliamson/blah.git /tmp/blah
Specific commits can be selected by appending a hash to the URI,
followed by the name of the commit:
    blah.fetch("git+https://github.com/mwilliamson/blah.git#74d69b4", "/tmp/blah")
At the moment, git and hg URIs are supported.

%package -n python3-blah
Summary:	Thin wrapper around source control systems
Provides:	python-blah
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-blah
**This package is deprecated.** Blah has been renamed to `Mayo <https://pypi.python.org/pypi/mayo>`_. Please use the package ``mayo`` instead.
The main use of Blah is being able to download repositories from a URI
that specifies what version control system (VCS) is being used:
    import blah
    blah.fetch("git+https://github.com/mwilliamson/blah.git", "/tmp/blah")
    print open("/tmp/blah/README.md").read()
Blah can also be used as a script:
    blah fetch git+https://github.com/mwilliamson/blah.git /tmp/blah
Specific commits can be selected by appending a hash to the URI,
followed by the name of the commit:
    blah.fetch("git+https://github.com/mwilliamson/blah.git#74d69b4", "/tmp/blah")
At the moment, git and hg URIs are supported.

%package help
Summary:	Development documents and examples for blah
Provides:	python3-blah-doc
%description help
**This package is deprecated.** Blah has been renamed to `Mayo <https://pypi.python.org/pypi/mayo>`_. Please use the package ``mayo`` instead.
The main use of Blah is being able to download repositories from a URI
that specifies what version control system (VCS) is being used:
    import blah
    blah.fetch("git+https://github.com/mwilliamson/blah.git", "/tmp/blah")
    print open("/tmp/blah/README.md").read()
Blah can also be used as a script:
    blah fetch git+https://github.com/mwilliamson/blah.git /tmp/blah
Specific commits can be selected by appending a hash to the URI,
followed by the name of the commit:
    blah.fetch("git+https://github.com/mwilliamson/blah.git#74d69b4", "/tmp/blah")
At the moment, git and hg URIs are supported.

%prep
%autosetup -n blah-0.1.12

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-blah -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.12-1
- Package Spec generated