%global _empty_manifest_terminate_build 0
Name:		python-amlpp
Version:	0.1.9.7
Release:	1
Summary:	Wrapper for ml library
License:	MIT License
URL:		https://github.com/Asirg/amlpp
Source0:	https://mirrors.aliyun.com/pypi/web/packages/b8/09/16ea6bdd22d8a308c1e269c564fcf06cfde7b345e3d0d6c87582633e6e30/amlpp-0.1.9.7.tar.gz
BuildArch:	noarch

Requires:	python3-scikit-learn
Requires:	python3-matplotlib
Requires:	python3-pymorphy2
Requires:	python3-lightgbm
Requires:	python3-catboost
Requires:	python3-xgboost
Requires:	python3-typing
Requires:	python3-gensim
Requires:	python3-optuna
Requires:	python3-numpy
Requires:	python3-shap
Requires:	python3-TPOT
Requires:	python3-tqdm
Requires:	python3-nltk

%description
# Description

library wrapper for ml libraries.

### Сapabilities
The main class is a conveyor as an analogue of a pipeline. There is a partial interchangeability. The focus is on expanding built-in capabilities such as auto-typing predictive models, feature importance inference, scores, and various future features. There are also adapted transformers, classes for customizing the structure of projects.

### Status
At the moment, the functionality is not wide, designed for expansion in the future



%package -n python3-amlpp
Summary:	Wrapper for ml library
Provides:	python-amlpp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-amlpp
# Description

library wrapper for ml libraries.

### Сapabilities
The main class is a conveyor as an analogue of a pipeline. There is a partial interchangeability. The focus is on expanding built-in capabilities such as auto-typing predictive models, feature importance inference, scores, and various future features. There are also adapted transformers, classes for customizing the structure of projects.

### Status
At the moment, the functionality is not wide, designed for expansion in the future



%package help
Summary:	Development documents and examples for amlpp
Provides:	python3-amlpp-doc
%description help
# Description

library wrapper for ml libraries.

### Сapabilities
The main class is a conveyor as an analogue of a pipeline. There is a partial interchangeability. The focus is on expanding built-in capabilities such as auto-typing predictive models, feature importance inference, scores, and various future features. There are also adapted transformers, classes for customizing the structure of projects.

### Status
At the moment, the functionality is not wide, designed for expansion in the future



%prep
%autosetup -n amlpp-0.1.9.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-amlpp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.9.7-1
- Package Spec generated