%global _empty_manifest_terminate_build 0
Name:		python-acky
Version:	0.2.3
Release:	1
Summary:	A consistent API to AWS
License:	MIT
URL:		http://github.com/RetailMeNot/acky
Source0:	https://mirrors.aliyun.com/pypi/web/packages/21/58/035abe1fc735cb649778c45a445d008a914febec8b2215283f7b2a21fda4/acky-0.2.3.tar.gz
BuildArch:	noarch

Requires:	python3-botocore

%description
%%%%%%%%%%%%
Acky Library
%%%%%%%%%%%%

.. image:: https://travis-ci.org/RetailMeNot/acky.svg?branch=master
   :target: https://travis-ci.org/RetailMeNot/acky
   :alt: Build Status

The Acky library provides a consistent interface to AWS. Based on botocore, it
abstracts some of the API work involved and allows the user to interact with AWS
APIs in a consistent way with minimal overhead.

Acky takes a different approach to the API from libraries like the venerable
`Boto <https://github.com/boto/boto>`. Rather than model AWS objects as Python
objects, Acky simply wraps the API to provide a more consistent interface. Most
objects in AWS are represented as collections in Acky, with get(), create(),
and destroy() methods. The get() method always accepts a filter map, no matter
if the underlying API method does.

In cases where the API's multitude of parameters would make for awkward method
calls (as is the case with EC2's RunInstances), Acky provides a utility class
whose attributes can be set before executing the API call.


%%%%%%%%%%
Using Acky
%%%%%%%%%%

Acky uses a botocore-style AWS credential configuration, the same as the
official AWS CLI. Before you use Acky, you'll need to `set up your config
<http://docs.aws.amazon.com/cli/latest/userguide/cli-chap-getting-started.html>`.

Once your credentials are set up, using acky is as simple as creating an
instance of the AWS object::

    from acky.aws import AWS
    aws = AWS(region, profile)
    instances = aws.ec2.Instances.get(filters={'tag:Name': 'web-*'})
    print('Found {} web servers'.format(len(instances)))
    for instance in instances:
        print('  {}'.format(instance['PublicDnsName'])


%%%%%%%%%%%%%%%%
Module Structure
%%%%%%%%%%%%%%%%

The expected module structure for Acky follows. Many APIs are not yet
implemented, but those that are can be considered stable.

* AWS

  * username (property)
  * userinfo (property)
  * account_id (property)
  * environment (property)
  * ec2

    * regions
    * zones
    * ACEs
    * ACLs
    * ElasticIPs
    * Instances
    * IpPermissions
    * KeyPairs
    * PlacementGroups
    * SecurityGroups
    * Snapshots
    * Subnets
    * VPCs
    * Volumes

  * iam

    * Users
    * Groups
    * Keys

  * rds

    * engine_versions
    * Instances
    * Snapshots
    * EventSubscriptions
    * SecurityGroups
    * SecurityGroupRules

  * sqs

    * Queues
    * Messages

  * sts

    * GetFederationToken
    * GetSessionToken

Other services will be added in future versions.

%%%%%%%%%%%%%%%%%%
Installing acky
%%%%%%%%%%%%%%%%%%

acky is available in PyPI and is installable via pip::

    pip install acky

You may also install acky from source, perhaps from the GitHub repo::

    git clone https://github.com/RetailMeNot/acky.git
    cd acky
    python setup.py install

%package -n python3-acky
Summary:	A consistent API to AWS
Provides:	python-acky
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-acky
%%%%%%%%%%%%
Acky Library
%%%%%%%%%%%%

.. image:: https://travis-ci.org/RetailMeNot/acky.svg?branch=master
   :target: https://travis-ci.org/RetailMeNot/acky
   :alt: Build Status

The Acky library provides a consistent interface to AWS. Based on botocore, it
abstracts some of the API work involved and allows the user to interact with AWS
APIs in a consistent way with minimal overhead.

Acky takes a different approach to the API from libraries like the venerable
`Boto <https://github.com/boto/boto>`. Rather than model AWS objects as Python
objects, Acky simply wraps the API to provide a more consistent interface. Most
objects in AWS are represented as collections in Acky, with get(), create(),
and destroy() methods. The get() method always accepts a filter map, no matter
if the underlying API method does.

In cases where the API's multitude of parameters would make for awkward method
calls (as is the case with EC2's RunInstances), Acky provides a utility class
whose attributes can be set before executing the API call.


%%%%%%%%%%
Using Acky
%%%%%%%%%%

Acky uses a botocore-style AWS credential configuration, the same as the
official AWS CLI. Before you use Acky, you'll need to `set up your config
<http://docs.aws.amazon.com/cli/latest/userguide/cli-chap-getting-started.html>`.

Once your credentials are set up, using acky is as simple as creating an
instance of the AWS object::

    from acky.aws import AWS
    aws = AWS(region, profile)
    instances = aws.ec2.Instances.get(filters={'tag:Name': 'web-*'})
    print('Found {} web servers'.format(len(instances)))
    for instance in instances:
        print('  {}'.format(instance['PublicDnsName'])


%%%%%%%%%%%%%%%%
Module Structure
%%%%%%%%%%%%%%%%

The expected module structure for Acky follows. Many APIs are not yet
implemented, but those that are can be considered stable.

* AWS

  * username (property)
  * userinfo (property)
  * account_id (property)
  * environment (property)
  * ec2

    * regions
    * zones
    * ACEs
    * ACLs
    * ElasticIPs
    * Instances
    * IpPermissions
    * KeyPairs
    * PlacementGroups
    * SecurityGroups
    * Snapshots
    * Subnets
    * VPCs
    * Volumes

  * iam

    * Users
    * Groups
    * Keys

  * rds

    * engine_versions
    * Instances
    * Snapshots
    * EventSubscriptions
    * SecurityGroups
    * SecurityGroupRules

  * sqs

    * Queues
    * Messages

  * sts

    * GetFederationToken
    * GetSessionToken

Other services will be added in future versions.

%%%%%%%%%%%%%%%%%%
Installing acky
%%%%%%%%%%%%%%%%%%

acky is available in PyPI and is installable via pip::

    pip install acky

You may also install acky from source, perhaps from the GitHub repo::

    git clone https://github.com/RetailMeNot/acky.git
    cd acky
    python setup.py install

%package help
Summary:	Development documents and examples for acky
Provides:	python3-acky-doc
%description help
%%%%%%%%%%%%
Acky Library
%%%%%%%%%%%%

.. image:: https://travis-ci.org/RetailMeNot/acky.svg?branch=master
   :target: https://travis-ci.org/RetailMeNot/acky
   :alt: Build Status

The Acky library provides a consistent interface to AWS. Based on botocore, it
abstracts some of the API work involved and allows the user to interact with AWS
APIs in a consistent way with minimal overhead.

Acky takes a different approach to the API from libraries like the venerable
`Boto <https://github.com/boto/boto>`. Rather than model AWS objects as Python
objects, Acky simply wraps the API to provide a more consistent interface. Most
objects in AWS are represented as collections in Acky, with get(), create(),
and destroy() methods. The get() method always accepts a filter map, no matter
if the underlying API method does.

In cases where the API's multitude of parameters would make for awkward method
calls (as is the case with EC2's RunInstances), Acky provides a utility class
whose attributes can be set before executing the API call.


%%%%%%%%%%
Using Acky
%%%%%%%%%%

Acky uses a botocore-style AWS credential configuration, the same as the
official AWS CLI. Before you use Acky, you'll need to `set up your config
<http://docs.aws.amazon.com/cli/latest/userguide/cli-chap-getting-started.html>`.

Once your credentials are set up, using acky is as simple as creating an
instance of the AWS object::

    from acky.aws import AWS
    aws = AWS(region, profile)
    instances = aws.ec2.Instances.get(filters={'tag:Name': 'web-*'})
    print('Found {} web servers'.format(len(instances)))
    for instance in instances:
        print('  {}'.format(instance['PublicDnsName'])


%%%%%%%%%%%%%%%%
Module Structure
%%%%%%%%%%%%%%%%

The expected module structure for Acky follows. Many APIs are not yet
implemented, but those that are can be considered stable.

* AWS

  * username (property)
  * userinfo (property)
  * account_id (property)
  * environment (property)
  * ec2

    * regions
    * zones
    * ACEs
    * ACLs
    * ElasticIPs
    * Instances
    * IpPermissions
    * KeyPairs
    * PlacementGroups
    * SecurityGroups
    * Snapshots
    * Subnets
    * VPCs
    * Volumes

  * iam

    * Users
    * Groups
    * Keys

  * rds

    * engine_versions
    * Instances
    * Snapshots
    * EventSubscriptions
    * SecurityGroups
    * SecurityGroupRules

  * sqs

    * Queues
    * Messages

  * sts

    * GetFederationToken
    * GetSessionToken

Other services will be added in future versions.

%%%%%%%%%%%%%%%%%%
Installing acky
%%%%%%%%%%%%%%%%%%

acky is available in PyPI and is installable via pip::

    pip install acky

You may also install acky from source, perhaps from the GitHub repo::

    git clone https://github.com/RetailMeNot/acky.git
    cd acky
    python setup.py install

%prep
%autosetup -n acky-0.2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-acky -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.3-1
- Package Spec generated