%global _empty_manifest_terminate_build 0
Name:		python-tsetmc
Version:	0.48.2
Release:	1
Summary:	a library to retrieve data from tsetmc.com website
License:	GNU General Public License v3 (GPLv3)
URL:		https://github.com/5j9/tsetmc
Source0:	https://mirrors.aliyun.com/pypi/web/packages/86/32/ec0a4d0c69aa2a8788f82907f1e7de042cd2b7c599f615ad4b0ce0457795/tsetmc-0.48.2.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp[speedups]
Requires:	python3-yarl
Requires:	python3-jdatetime
Requires:	python3-pandas
Requires:	python3-numpy
Requires:	python3-beautifulsoup4
Requires:	python3-lxml
Requires:	python3-aiohttp-test-utils

%description
Requires latest stable Python version.
``pip install tsetmc``

%package -n python3-tsetmc
Summary:	a library to retrieve data from tsetmc.com website
Provides:	python-tsetmc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tsetmc
Requires latest stable Python version.
``pip install tsetmc``

%package help
Summary:	Development documents and examples for tsetmc
Provides:	python3-tsetmc-doc
%description help
Requires latest stable Python version.
``pip install tsetmc``

%prep
%autosetup -n tsetmc-0.48.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tsetmc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.48.2-1
- Package Spec generated