%global _empty_manifest_terminate_build 0 Name: python-git42 Version: 2021.1.31 Release: 1 Summary: git init, add, commit and push with one command License: Unlicense URL: https://github.com/andrewp-as-is/git42 Source0: https://mirrors.aliyun.com/pypi/web/packages/13/a1/9de22d7d886dde2fa49c671d016e2757a07e05559e0ff551dd5a1003553a/git42-2021.1.31.tar.gz BuildArch: noarch %description [![](https://img.shields.io/badge/OS-Unix-blue.svg?longCache=True)]() [![](https://img.shields.io/pypi/v/git42.svg?maxAge=3600)](https://pypi.org/project/git42/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install git42 ``` ```bash $ [sudo] npm i -g git42 ``` #### Examples ```bash git42 path/to/repo1 git42 path/to/repo2 path/to/repo3 ```

readme42.com

%package -n python3-git42 Summary: git init, add, commit and push with one command Provides: python-git42 BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-git42 [![](https://img.shields.io/badge/OS-Unix-blue.svg?longCache=True)]() [![](https://img.shields.io/pypi/v/git42.svg?maxAge=3600)](https://pypi.org/project/git42/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install git42 ``` ```bash $ [sudo] npm i -g git42 ``` #### Examples ```bash git42 path/to/repo1 git42 path/to/repo2 path/to/repo3 ```

readme42.com

%package help Summary: Development documents and examples for git42 Provides: python3-git42-doc %description help [![](https://img.shields.io/badge/OS-Unix-blue.svg?longCache=True)]() [![](https://img.shields.io/pypi/v/git42.svg?maxAge=3600)](https://pypi.org/project/git42/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install git42 ``` ```bash $ [sudo] npm i -g git42 ``` #### Examples ```bash git42 path/to/repo1 git42 path/to/repo2 path/to/repo3 ```

readme42.com

%prep %autosetup -n git42-2021.1.31 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-git42 -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri Jun 09 2023 Python_Bot - 2021.1.31-1 - Package Spec generated