%global _empty_manifest_terminate_build 0
Name: python-django-octicons
Version: 1.0.2
Release: 1
Summary: Django templatetags for GitHub's Octicons.
License: MIT
URL: https://github.com/sanketsaurav/django-octicons
Source0: https://mirrors.aliyun.com/pypi/web/packages/42/c0/e79ab9d3768527fa46e4fa8c0cf06d1abd193b886f54b1db0468354960a1/django-octicons-1.0.2.tar.gz
BuildArch: noarch
Requires: python3-django
%description
# django-octicons
[![Build Status](https://travis-ci.org/sanketsaurav/django-octicons.svg?branch=master)](https://travis-ci.org/sanketsaurav/django-octicons)
Template tags for Django to use [GitHub Octicons](https://octicons.github.com/).
## Installation
Grab it from PyPI using pipenv (or pip):
```sh
$ pipenv install django-octicons
```
Install the app in your project:
```python
# settings.py
INSTALLED_APPS = [
# other apps
'octicons',
]
```
## Usage
Load the tag library in your HTML template:
```html
{% load octicons %}
```
And then, you can use the icons like this:
```html
{% octicon "eye" %}
Watch
```
You can also pass any required attributes:
```html
{% octicon "thumbsup" height="60" class="large" %}
Confirm Purchase
```
All attributes passed will be added as HTML attributes to the SVG element
of the icon.
### Styling
You should add the following in your styles:
```css
.octicon {
display: inline-block;
vertical-align: text-top;
fill: currentColor;
}
```
The class `octicon` will be present in all icons. You are free to style it however you want.
%package -n python3-django-octicons
Summary: Django templatetags for GitHub's Octicons.
Provides: python-django-octicons
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-octicons
# django-octicons
[![Build Status](https://travis-ci.org/sanketsaurav/django-octicons.svg?branch=master)](https://travis-ci.org/sanketsaurav/django-octicons)
Template tags for Django to use [GitHub Octicons](https://octicons.github.com/).
## Installation
Grab it from PyPI using pipenv (or pip):
```sh
$ pipenv install django-octicons
```
Install the app in your project:
```python
# settings.py
INSTALLED_APPS = [
# other apps
'octicons',
]
```
## Usage
Load the tag library in your HTML template:
```html
{% load octicons %}
```
And then, you can use the icons like this:
```html
{% octicon "eye" %}
Watch
```
You can also pass any required attributes:
```html
{% octicon "thumbsup" height="60" class="large" %}
Confirm Purchase
```
All attributes passed will be added as HTML attributes to the SVG element
of the icon.
### Styling
You should add the following in your styles:
```css
.octicon {
display: inline-block;
vertical-align: text-top;
fill: currentColor;
}
```
The class `octicon` will be present in all icons. You are free to style it however you want.
%package help
Summary: Development documents and examples for django-octicons
Provides: python3-django-octicons-doc
%description help
# django-octicons
[![Build Status](https://travis-ci.org/sanketsaurav/django-octicons.svg?branch=master)](https://travis-ci.org/sanketsaurav/django-octicons)
Template tags for Django to use [GitHub Octicons](https://octicons.github.com/).
## Installation
Grab it from PyPI using pipenv (or pip):
```sh
$ pipenv install django-octicons
```
Install the app in your project:
```python
# settings.py
INSTALLED_APPS = [
# other apps
'octicons',
]
```
## Usage
Load the tag library in your HTML template:
```html
{% load octicons %}
```
And then, you can use the icons like this:
```html
{% octicon "eye" %}
Watch
```
You can also pass any required attributes:
```html
{% octicon "thumbsup" height="60" class="large" %}
Confirm Purchase
```
All attributes passed will be added as HTML attributes to the SVG element
of the icon.
### Styling
You should add the following in your styles:
```css
.octicon {
display: inline-block;
vertical-align: text-top;
fill: currentColor;
}
```
The class `octicon` will be present in all icons. You are free to style it however you want.
%prep
%autosetup -n django-octicons-1.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-octicons -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 1.0.2-1
- Package Spec generated