%global _empty_manifest_terminate_build 0
Name:		python-bothub
Version:	0.1.30
Release:	1
Summary:	Build serverless chatbot on BotHub.Studio
License:	AGPL v3
URL:		https://github.com/bothub-studio/bothub-sdk-python
Source0:	https://mirrors.aliyun.com/pypi/web/packages/2c/fe/a933ea17b12f5e7b8d073b624e5c64289df278b760aa7240a1af22e9b486/bothub-0.1.30.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-zmq
Requires:	python3-pyaml

%description


%package -n python3-bothub
Summary:	Build serverless chatbot on BotHub.Studio
Provides:	python-bothub
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bothub


%package help
Summary:	Development documents and examples for bothub
Provides:	python3-bothub-doc
%description help


%prep
%autosetup -n bothub-0.1.30

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bothub -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.30-1
- Package Spec generated