%global _empty_manifest_terminate_build 0
Name:		python-tilequant
Version:	0.4.1.post1
Release:	1
Summary:	Tool for quantizing image colors using tile-based palette restrictions
License:	GNU General Public License v3 or later (GPLv3+)
URL:		https://github.com/SkyTemple/tilequant/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/4f/28/f8b421b262a39c12566cfb2ea16838b774ee8456b2eea2e869f6759b05ce/tilequant-0.4.1.post1.tar.gz

Requires:	python3-Pillow
Requires:	python3-ordered-set
Requires:	python3-sortedcollections
Requires:	python3-click

%description
|build| |pypi-version| |pypi-downloads| |pypi-license| |pypi-pyversions|
Tilequant is a utility to reduce the colors in an image (quantizing). The current version
is based on `Tilequant by Aikku93`_ (the same name is coincidental)).
It does so by limiting each tile (by default an area of 8x8 pixels) of the image
to a subset of colors (a palette). The whole image has one big palette that consists of
those smaller palettes.
This tool is a standalone part of SkyTemple, the ROM editor for
Pokémon Mystery Dungeon Explorers of Sky.
By default it produces images that can be used by SkyTemple.
However the images are probably also useful
for use with other games that have similar restrictions for backgrounds.
Make sure the input image is a RGB image without an alpha channel. The image library used
has some problems with converting other image types to RGB in some cases.
The output is an image with a palettes as shown in the example.
(This example is based on the old legacy version).
This tool is not affiliated with Nintendo, Spike Chunsoft or any of the parties involved in
creating Pokémon Mystery Dungeon Explorers of Sky. This is a fan-project.

%package -n python3-tilequant
Summary:	Tool for quantizing image colors using tile-based palette restrictions
Provides:	python-tilequant
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-tilequant
|build| |pypi-version| |pypi-downloads| |pypi-license| |pypi-pyversions|
Tilequant is a utility to reduce the colors in an image (quantizing). The current version
is based on `Tilequant by Aikku93`_ (the same name is coincidental)).
It does so by limiting each tile (by default an area of 8x8 pixels) of the image
to a subset of colors (a palette). The whole image has one big palette that consists of
those smaller palettes.
This tool is a standalone part of SkyTemple, the ROM editor for
Pokémon Mystery Dungeon Explorers of Sky.
By default it produces images that can be used by SkyTemple.
However the images are probably also useful
for use with other games that have similar restrictions for backgrounds.
Make sure the input image is a RGB image without an alpha channel. The image library used
has some problems with converting other image types to RGB in some cases.
The output is an image with a palettes as shown in the example.
(This example is based on the old legacy version).
This tool is not affiliated with Nintendo, Spike Chunsoft or any of the parties involved in
creating Pokémon Mystery Dungeon Explorers of Sky. This is a fan-project.

%package help
Summary:	Development documents and examples for tilequant
Provides:	python3-tilequant-doc
%description help
|build| |pypi-version| |pypi-downloads| |pypi-license| |pypi-pyversions|
Tilequant is a utility to reduce the colors in an image (quantizing). The current version
is based on `Tilequant by Aikku93`_ (the same name is coincidental)).
It does so by limiting each tile (by default an area of 8x8 pixels) of the image
to a subset of colors (a palette). The whole image has one big palette that consists of
those smaller palettes.
This tool is a standalone part of SkyTemple, the ROM editor for
Pokémon Mystery Dungeon Explorers of Sky.
By default it produces images that can be used by SkyTemple.
However the images are probably also useful
for use with other games that have similar restrictions for backgrounds.
Make sure the input image is a RGB image without an alpha channel. The image library used
has some problems with converting other image types to RGB in some cases.
The output is an image with a palettes as shown in the example.
(This example is based on the old legacy version).
This tool is not affiliated with Nintendo, Spike Chunsoft or any of the parties involved in
creating Pokémon Mystery Dungeon Explorers of Sky. This is a fan-project.

%prep
%autosetup -n tilequant-0.4.1.post1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tilequant -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1.post1-1
- Package Spec generated