%global _empty_manifest_terminate_build 0
Name: python-biomass
Version: 0.12.0
Release: 1
Summary: A Python Framework for Modeling and Analysis of Signaling Systems
License: Apache-2.0
URL: https://pypi.org/project/biomass/
Source0: https://mirrors.aliyun.com/pypi/web/packages/4f/07/1dc5ae8a39bba186d1b272f2432e0e08b6ee8b58950995961609334556c0/biomass-0.12.0.tar.gz
BuildArch: noarch
Requires: python3-matplotlib
Requires: python3-numba
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-scipy
Requires: python3-seaborn
Requires: python3-tqdm
Requires: python3-black
Requires: python3-flake8
Requires: python3-isort
Requires: python3-pre-commit
Requires: python3-pytest
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-sphinx-autodoc-typehints
Requires: python3-sphinxcontrib-bibtex
Requires: python3-pygraphviz
Requires: python3-pyvis
%description
[](https://pypi.python.org/pypi/biomass)
[](https://github.com/biomass-dev/biomass/actions)
[](https://biomass-core.readthedocs.io/en/latest/?badge=latest)
[](https://opensource.org/licenses/Apache-2.0)
[](https://pepy.tech/project/biomass)
[](https://pypi.python.org/pypi/biomass)
[](https://results.pre-commit.ci/latest/github/biomass-dev/biomass/master)
[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://doi.org/10.3390/cancers12102878)
_BioMASS_ is a computational framework for modeling and analysis of biological signaling systems in Python.
- **Documentation:** https://biomass-core.rtfd.io
- **Source code:** https://github.com/biomass-dev/biomass
- **Bug reports:** https://github.com/biomass-dev/biomass/issues
- **Citing in your work:** https://biomass-core.rtfd.io/en/latest/citing.html
It provides useful tools for numerical simulation, parameter estimation, network analysis, and result visualization.
## Installation
The BioMASS library is available at the [Python Package Index (PyPI)](https://pypi.org/project/biomass).
```shell
$ pip install biomass
```
BioMASS supports Python 3.8 or newer.
## References
- Imoto, H., Zhang, S. & Okada, M. A Computational Framework for Prediction and Analysis of Cancer Signaling Dynamics from RNA Sequencing Data—Application to the ErbB Receptor Signaling Pathway. _Cancers_ **12**, 2878 (2020). https://doi.org/10.3390/cancers12102878
- Imoto, H., Yamashiro, S. & Okada, M. A text-based computational framework for patient -specific modeling for classification of cancers. _iScience_ **25**, 103944 (2022). https://doi.org/10.1016/j.isci.2022.103944
## Author
[Hiroaki Imoto](https://github.com/himoto)
## License
[Apache License 2.0](https://github.com/biomass-dev/biomass/blob/master/LICENSE)
%package -n python3-biomass
Summary: A Python Framework for Modeling and Analysis of Signaling Systems
Provides: python-biomass
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-biomass
[](https://pypi.python.org/pypi/biomass)
[](https://github.com/biomass-dev/biomass/actions)
[](https://biomass-core.readthedocs.io/en/latest/?badge=latest)
[](https://opensource.org/licenses/Apache-2.0)
[](https://pepy.tech/project/biomass)
[](https://pypi.python.org/pypi/biomass)
[](https://results.pre-commit.ci/latest/github/biomass-dev/biomass/master)
[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://doi.org/10.3390/cancers12102878)
_BioMASS_ is a computational framework for modeling and analysis of biological signaling systems in Python.
- **Documentation:** https://biomass-core.rtfd.io
- **Source code:** https://github.com/biomass-dev/biomass
- **Bug reports:** https://github.com/biomass-dev/biomass/issues
- **Citing in your work:** https://biomass-core.rtfd.io/en/latest/citing.html
It provides useful tools for numerical simulation, parameter estimation, network analysis, and result visualization.
## Installation
The BioMASS library is available at the [Python Package Index (PyPI)](https://pypi.org/project/biomass).
```shell
$ pip install biomass
```
BioMASS supports Python 3.8 or newer.
## References
- Imoto, H., Zhang, S. & Okada, M. A Computational Framework for Prediction and Analysis of Cancer Signaling Dynamics from RNA Sequencing Data—Application to the ErbB Receptor Signaling Pathway. _Cancers_ **12**, 2878 (2020). https://doi.org/10.3390/cancers12102878
- Imoto, H., Yamashiro, S. & Okada, M. A text-based computational framework for patient -specific modeling for classification of cancers. _iScience_ **25**, 103944 (2022). https://doi.org/10.1016/j.isci.2022.103944
## Author
[Hiroaki Imoto](https://github.com/himoto)
## License
[Apache License 2.0](https://github.com/biomass-dev/biomass/blob/master/LICENSE)
%package help
Summary: Development documents and examples for biomass
Provides: python3-biomass-doc
%description help
[](https://pypi.python.org/pypi/biomass)
[](https://github.com/biomass-dev/biomass/actions)
[](https://biomass-core.readthedocs.io/en/latest/?badge=latest)
[](https://opensource.org/licenses/Apache-2.0)
[](https://pepy.tech/project/biomass)
[](https://pypi.python.org/pypi/biomass)
[](https://results.pre-commit.ci/latest/github/biomass-dev/biomass/master)
[](https://github.com/psf/black)
[](https://pycqa.github.io/isort/)
[](https://doi.org/10.3390/cancers12102878)
_BioMASS_ is a computational framework for modeling and analysis of biological signaling systems in Python.
- **Documentation:** https://biomass-core.rtfd.io
- **Source code:** https://github.com/biomass-dev/biomass
- **Bug reports:** https://github.com/biomass-dev/biomass/issues
- **Citing in your work:** https://biomass-core.rtfd.io/en/latest/citing.html
It provides useful tools for numerical simulation, parameter estimation, network analysis, and result visualization.
## Installation
The BioMASS library is available at the [Python Package Index (PyPI)](https://pypi.org/project/biomass).
```shell
$ pip install biomass
```
BioMASS supports Python 3.8 or newer.
## References
- Imoto, H., Zhang, S. & Okada, M. A Computational Framework for Prediction and Analysis of Cancer Signaling Dynamics from RNA Sequencing Data—Application to the ErbB Receptor Signaling Pathway. _Cancers_ **12**, 2878 (2020). https://doi.org/10.3390/cancers12102878
- Imoto, H., Yamashiro, S. & Okada, M. A text-based computational framework for patient -specific modeling for classification of cancers. _iScience_ **25**, 103944 (2022). https://doi.org/10.1016/j.isci.2022.103944
## Author
[Hiroaki Imoto](https://github.com/himoto)
## License
[Apache License 2.0](https://github.com/biomass-dev/biomass/blob/master/LICENSE)
%prep
%autosetup -n biomass-0.12.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-biomass -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Jun 09 2023 Python_Bot - 0.12.0-1
- Package Spec generated