%global _empty_manifest_terminate_build 0
Name:		python-simple-manga-downloader
Version:	1.16.1
Release:	1
Summary:	Simple manga console downloader
License:	GPLv3
URL:		https://github.com/Kanjirito/simple-manga-downloader
Source0:	https://mirrors.aliyun.com/pypi/web/packages/8f/4a/e5c1657374e25e2cf9a1a719ad7520588ec0697ceff46615a0867bb4c3ed/simple-manga-downloader-1.16.1.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-beautifulsoup4
Requires:	python3-urllib3

%description
# simple-manga-downloader
Simple manga console downloader written in python. Made for Linux but should work on any platform.

Currently supports:

- [mangadex](https://mangadex.org)
- [mangatown](https://www.mangatown.com)
- [mangakakalot](https://mangakakalot.com/page)
- [manganato](https://manganato.com/)

*Note:* mangadex is the main supported site, the others *might* be maintained but they are not my top priority.

Allows you to download manga in 5 ways:

- all chapters of a series
- a range of chapters (from 5 to 15)
- a selection of chapters (5, 7, 10, 20)
- only the newest chapter
- check for new chapters for the tracked manga

Additional features of the downloader:

- It will check if a chapter on mangadex.org has multiple uploads by different groups and ask which one to download
- It handles the MangaPlus chapters on mangadex
- Allows to use data saver images from Mangadex
- It can download the cover(s) for the manga (off by default)
- You can specify the language (mangadex only)
- You can specify which chapters to exclude from the download
- You can change the directory where the manga is saved
- You can add ongoing manga to the tracked list for a easy way to check for new chapters
- Config is saved as a .json for readability and easy modification
- The downloader has a config "mode" that allows the modification of the config file without having to edit the .json manually
- It can check for new available versions
- It will remove (or replace) characters from titles that could cause problems, by default removes `/ \ | ? > < . : ? * "`


# Installation

## Requirements
- BeautifulSoup 4
- requests

## Releases form PyPI

Installing using pip will handle the requirements automatically. I would also recommend using [pipx](https://github.com/pipxproject/pipx) instead of just pip.

```
pip install simple-manga-downloader
```

## Using the git repo

### Installing using pip

To install from the master branch

```
pip install git+https://github.com/Kanjirito/simple-manga-downloader@master
```

### Using the git repo without installing

Copy the repo, install the requirements and use the entry script in the main repo directory
```
cd path/to/repo
chmod +x SMD.py
pip install -r requirements.txt
./SMD.py [mode] [arguments]
```


# USAGE

## General info

For all commands you can either use `SMD` or `smd`.

The default manga download directory is `~/Manga` this can be changed in the config file or in the command. The config directory is `$XDG_CONFIG_HOME/SMD` (`~/.config/SMD` if variable not set), you can specify a different config to be used like this:

```
SMD -c "path/to/config" mode arguments
```

Examples:
```
SMD -c "~/Downloader/config.json" down link_to_manga -l
SMD -c "~/Downloader/config.json" update
```
To create the config file the downloader needs to successfully finish. If you want to have the config created before you use the downloader you can do:
```
SMD conf
```

## Details
For a more detailed explanation of the modes and their available arguments read the [USAGE.md](USAGE.md) file in the git repo.

# Changelog

Changelog can be found in [CHANGELOG.md](CHANGELOG.md) in the git repo.




%package -n python3-simple-manga-downloader
Summary:	Simple manga console downloader
Provides:	python-simple-manga-downloader
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-simple-manga-downloader
# simple-manga-downloader
Simple manga console downloader written in python. Made for Linux but should work on any platform.

Currently supports:

- [mangadex](https://mangadex.org)
- [mangatown](https://www.mangatown.com)
- [mangakakalot](https://mangakakalot.com/page)
- [manganato](https://manganato.com/)

*Note:* mangadex is the main supported site, the others *might* be maintained but they are not my top priority.

Allows you to download manga in 5 ways:

- all chapters of a series
- a range of chapters (from 5 to 15)
- a selection of chapters (5, 7, 10, 20)
- only the newest chapter
- check for new chapters for the tracked manga

Additional features of the downloader:

- It will check if a chapter on mangadex.org has multiple uploads by different groups and ask which one to download
- It handles the MangaPlus chapters on mangadex
- Allows to use data saver images from Mangadex
- It can download the cover(s) for the manga (off by default)
- You can specify the language (mangadex only)
- You can specify which chapters to exclude from the download
- You can change the directory where the manga is saved
- You can add ongoing manga to the tracked list for a easy way to check for new chapters
- Config is saved as a .json for readability and easy modification
- The downloader has a config "mode" that allows the modification of the config file without having to edit the .json manually
- It can check for new available versions
- It will remove (or replace) characters from titles that could cause problems, by default removes `/ \ | ? > < . : ? * "`


# Installation

## Requirements
- BeautifulSoup 4
- requests

## Releases form PyPI

Installing using pip will handle the requirements automatically. I would also recommend using [pipx](https://github.com/pipxproject/pipx) instead of just pip.

```
pip install simple-manga-downloader
```

## Using the git repo

### Installing using pip

To install from the master branch

```
pip install git+https://github.com/Kanjirito/simple-manga-downloader@master
```

### Using the git repo without installing

Copy the repo, install the requirements and use the entry script in the main repo directory
```
cd path/to/repo
chmod +x SMD.py
pip install -r requirements.txt
./SMD.py [mode] [arguments]
```


# USAGE

## General info

For all commands you can either use `SMD` or `smd`.

The default manga download directory is `~/Manga` this can be changed in the config file or in the command. The config directory is `$XDG_CONFIG_HOME/SMD` (`~/.config/SMD` if variable not set), you can specify a different config to be used like this:

```
SMD -c "path/to/config" mode arguments
```

Examples:
```
SMD -c "~/Downloader/config.json" down link_to_manga -l
SMD -c "~/Downloader/config.json" update
```
To create the config file the downloader needs to successfully finish. If you want to have the config created before you use the downloader you can do:
```
SMD conf
```

## Details
For a more detailed explanation of the modes and their available arguments read the [USAGE.md](USAGE.md) file in the git repo.

# Changelog

Changelog can be found in [CHANGELOG.md](CHANGELOG.md) in the git repo.




%package help
Summary:	Development documents and examples for simple-manga-downloader
Provides:	python3-simple-manga-downloader-doc
%description help
# simple-manga-downloader
Simple manga console downloader written in python. Made for Linux but should work on any platform.

Currently supports:

- [mangadex](https://mangadex.org)
- [mangatown](https://www.mangatown.com)
- [mangakakalot](https://mangakakalot.com/page)
- [manganato](https://manganato.com/)

*Note:* mangadex is the main supported site, the others *might* be maintained but they are not my top priority.

Allows you to download manga in 5 ways:

- all chapters of a series
- a range of chapters (from 5 to 15)
- a selection of chapters (5, 7, 10, 20)
- only the newest chapter
- check for new chapters for the tracked manga

Additional features of the downloader:

- It will check if a chapter on mangadex.org has multiple uploads by different groups and ask which one to download
- It handles the MangaPlus chapters on mangadex
- Allows to use data saver images from Mangadex
- It can download the cover(s) for the manga (off by default)
- You can specify the language (mangadex only)
- You can specify which chapters to exclude from the download
- You can change the directory where the manga is saved
- You can add ongoing manga to the tracked list for a easy way to check for new chapters
- Config is saved as a .json for readability and easy modification
- The downloader has a config "mode" that allows the modification of the config file without having to edit the .json manually
- It can check for new available versions
- It will remove (or replace) characters from titles that could cause problems, by default removes `/ \ | ? > < . : ? * "`


# Installation

## Requirements
- BeautifulSoup 4
- requests

## Releases form PyPI

Installing using pip will handle the requirements automatically. I would also recommend using [pipx](https://github.com/pipxproject/pipx) instead of just pip.

```
pip install simple-manga-downloader
```

## Using the git repo

### Installing using pip

To install from the master branch

```
pip install git+https://github.com/Kanjirito/simple-manga-downloader@master
```

### Using the git repo without installing

Copy the repo, install the requirements and use the entry script in the main repo directory
```
cd path/to/repo
chmod +x SMD.py
pip install -r requirements.txt
./SMD.py [mode] [arguments]
```


# USAGE

## General info

For all commands you can either use `SMD` or `smd`.

The default manga download directory is `~/Manga` this can be changed in the config file or in the command. The config directory is `$XDG_CONFIG_HOME/SMD` (`~/.config/SMD` if variable not set), you can specify a different config to be used like this:

```
SMD -c "path/to/config" mode arguments
```

Examples:
```
SMD -c "~/Downloader/config.json" down link_to_manga -l
SMD -c "~/Downloader/config.json" update
```
To create the config file the downloader needs to successfully finish. If you want to have the config created before you use the downloader you can do:
```
SMD conf
```

## Details
For a more detailed explanation of the modes and their available arguments read the [USAGE.md](USAGE.md) file in the git repo.

# Changelog

Changelog can be found in [CHANGELOG.md](CHANGELOG.md) in the git repo.




%prep
%autosetup -n simple-manga-downloader-1.16.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-simple-manga-downloader -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.16.1-1
- Package Spec generated