%global _empty_manifest_terminate_build 0 Name: python-djaodjin-saas Version: 0.16.2 Release: 1 Summary: Django application for software-as-service and subscription businesses License: BSD-2-Clause URL: https://pypi.org/project/djaodjin-saas/ Source0: https://mirrors.aliyun.com/pypi/web/packages/c7/b7/4121b1d9fd1e8c7c007b3381155e0a14362d41e73502596cf09cf8218ff6/djaodjin-saas-0.16.2.tar.gz BuildArch: noarch Requires: python3-Django Requires: python3-django-countries Requires: python3-django-localflavor Requires: python3-django-phonenumber-field Requires: python3-djangorestframework Requires: python3-Markdown Requires: python3-phonenumbers Requires: python3-dateutil Requires: python3-stripe Requires: python3-razorpay %description After cloning the repository, create a virtualenv environment and install the prerequisites:

    $ python -m venv .venv
    $ source .venv/bin/activate
    $ pip install -r testsite/requirements.txt
    # Installs Javascript prerequisites to run in the browser
    $ make vendor-assets-prerequisites
To use the testsite, you will need to add the payment processor keys (see [Processor Backends](http://djaodjin-saas.readthedocs.io/en/latest/backends.html)) and Django secret key into a credentials file. Example with [Stripe](https://stripe.com/):

    $ cat ./credentials
    SECRET_KEY = "enough_random_data"
    STRIPE_PUB_KEY = "your_stripe_public_api_key"
    STRIPE_PRIV_KEY = "your_stripe_private_api_key"
It remains to create and [populate the database with required objects](https://djaodjin-saas.readthedocs.io/en/latest/getting-started.html#setting-up-a-software-as-a-service-site). $ python ./manage.py migrate --run-syncdb --noinput $ python ./manage.py loaddata testsite/fixtures/initial_data.json $ python ./manage.py createsuperuser You can further generate a set of dummy data data to populate the site. $ python ./manage.py load_test_transactions Side note: If create your own fixtures file (ex: testsite/fixtures/test_data.json) and attempt to load them with a Django version *before* 2 while the Python executable was linked with a SQLite version *after* 3.25, you might stumble upon the well-known [SQLite 3.26 breaks database migration ForeignKey constraint, leaving __old in db schema](http://djaodjin.com/blog/django-2-2-with-sqlite-3-on-centos-7.blog.html#sqlite-django-compatibility) bug. Your best bet is to use Django2+ or delete the migrations/ directory. If all is well then, you are ready to run the server and browse the testsite. $ python manage.py runserver # Browse http://localhost:8000/ %package -n python3-djaodjin-saas Summary: Django application for software-as-service and subscription businesses Provides: python-djaodjin-saas BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-djaodjin-saas After cloning the repository, create a virtualenv environment and install the prerequisites:

    $ python -m venv .venv
    $ source .venv/bin/activate
    $ pip install -r testsite/requirements.txt
    # Installs Javascript prerequisites to run in the browser
    $ make vendor-assets-prerequisites
To use the testsite, you will need to add the payment processor keys (see [Processor Backends](http://djaodjin-saas.readthedocs.io/en/latest/backends.html)) and Django secret key into a credentials file. Example with [Stripe](https://stripe.com/):

    $ cat ./credentials
    SECRET_KEY = "enough_random_data"
    STRIPE_PUB_KEY = "your_stripe_public_api_key"
    STRIPE_PRIV_KEY = "your_stripe_private_api_key"
It remains to create and [populate the database with required objects](https://djaodjin-saas.readthedocs.io/en/latest/getting-started.html#setting-up-a-software-as-a-service-site). $ python ./manage.py migrate --run-syncdb --noinput $ python ./manage.py loaddata testsite/fixtures/initial_data.json $ python ./manage.py createsuperuser You can further generate a set of dummy data data to populate the site. $ python ./manage.py load_test_transactions Side note: If create your own fixtures file (ex: testsite/fixtures/test_data.json) and attempt to load them with a Django version *before* 2 while the Python executable was linked with a SQLite version *after* 3.25, you might stumble upon the well-known [SQLite 3.26 breaks database migration ForeignKey constraint, leaving __old in db schema](http://djaodjin.com/blog/django-2-2-with-sqlite-3-on-centos-7.blog.html#sqlite-django-compatibility) bug. Your best bet is to use Django2+ or delete the migrations/ directory. If all is well then, you are ready to run the server and browse the testsite. $ python manage.py runserver # Browse http://localhost:8000/ %package help Summary: Development documents and examples for djaodjin-saas Provides: python3-djaodjin-saas-doc %description help After cloning the repository, create a virtualenv environment and install the prerequisites:

    $ python -m venv .venv
    $ source .venv/bin/activate
    $ pip install -r testsite/requirements.txt
    # Installs Javascript prerequisites to run in the browser
    $ make vendor-assets-prerequisites
To use the testsite, you will need to add the payment processor keys (see [Processor Backends](http://djaodjin-saas.readthedocs.io/en/latest/backends.html)) and Django secret key into a credentials file. Example with [Stripe](https://stripe.com/):

    $ cat ./credentials
    SECRET_KEY = "enough_random_data"
    STRIPE_PUB_KEY = "your_stripe_public_api_key"
    STRIPE_PRIV_KEY = "your_stripe_private_api_key"
It remains to create and [populate the database with required objects](https://djaodjin-saas.readthedocs.io/en/latest/getting-started.html#setting-up-a-software-as-a-service-site). $ python ./manage.py migrate --run-syncdb --noinput $ python ./manage.py loaddata testsite/fixtures/initial_data.json $ python ./manage.py createsuperuser You can further generate a set of dummy data data to populate the site. $ python ./manage.py load_test_transactions Side note: If create your own fixtures file (ex: testsite/fixtures/test_data.json) and attempt to load them with a Django version *before* 2 while the Python executable was linked with a SQLite version *after* 3.25, you might stumble upon the well-known [SQLite 3.26 breaks database migration ForeignKey constraint, leaving __old in db schema](http://djaodjin.com/blog/django-2-2-with-sqlite-3-on-centos-7.blog.html#sqlite-django-compatibility) bug. Your best bet is to use Django2+ or delete the migrations/ directory. If all is well then, you are ready to run the server and browse the testsite. $ python manage.py runserver # Browse http://localhost:8000/ %prep %autosetup -n djaodjin-saas-0.16.2 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-djaodjin-saas -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 0.16.2-1 - Package Spec generated