%global _empty_manifest_terminate_build 0
Name:		python-vnpy-optionmaster
Version:	1.0.7
Release:	1
Summary:	Option volatility trading application for VeighNa quant trading framework.
License:	MIT
URL:		https://www.vnpy.com
Source0:	https://mirrors.aliyun.com/pypi/web/packages/76/da/2c7a29293d0ce661a895cc7d27ef37ecf302e64dcf567d139165682842aa/vnpy_optionmaster-1.0.7.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-exchange-calendars

%description
# VeighNa框架的期权波动率交易模块

<p align="center">
  <img src ="https://vnpy.oss-cn-shanghai.aliyuncs.com/vnpy-logo.png"/>
</p>

<p align="center">
    <img src ="https://img.shields.io/badge/version-1.0.7-blueviolet.svg"/>
    <img src ="https://img.shields.io/badge/platform-windows|linux|macos-yellow.svg"/>
    <img src ="https://img.shields.io/badge/python-3.7|3.8|3.9|3.10-blue.svg" />
    <img src ="https://img.shields.io/github/license/vnpy/vnpy.svg?color=orange"/>
</p>

## 说明

针对期权波动率交易类策略设计的应用模块,支持波动率曲面实时跟踪、期权组合持仓希腊值风控、Delta自动对冲算法、电子眼波动率执行算法、情景分析压力测试等功能。

## 安装

安装环境推荐基于3.0.0版本以上的【[**VeighNa Studio**](https://www.vnpy.com)】。

直接使用pip命令:

```
pip install vnpy_optionmaster
```


或者下载源代码后,解压后在cmd中运行:

```
pip install .
```


%package -n python3-vnpy-optionmaster
Summary:	Option volatility trading application for VeighNa quant trading framework.
Provides:	python-vnpy-optionmaster
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-vnpy-optionmaster
# VeighNa框架的期权波动率交易模块

<p align="center">
  <img src ="https://vnpy.oss-cn-shanghai.aliyuncs.com/vnpy-logo.png"/>
</p>

<p align="center">
    <img src ="https://img.shields.io/badge/version-1.0.7-blueviolet.svg"/>
    <img src ="https://img.shields.io/badge/platform-windows|linux|macos-yellow.svg"/>
    <img src ="https://img.shields.io/badge/python-3.7|3.8|3.9|3.10-blue.svg" />
    <img src ="https://img.shields.io/github/license/vnpy/vnpy.svg?color=orange"/>
</p>

## 说明

针对期权波动率交易类策略设计的应用模块,支持波动率曲面实时跟踪、期权组合持仓希腊值风控、Delta自动对冲算法、电子眼波动率执行算法、情景分析压力测试等功能。

## 安装

安装环境推荐基于3.0.0版本以上的【[**VeighNa Studio**](https://www.vnpy.com)】。

直接使用pip命令:

```
pip install vnpy_optionmaster
```


或者下载源代码后,解压后在cmd中运行:

```
pip install .
```


%package help
Summary:	Development documents and examples for vnpy-optionmaster
Provides:	python3-vnpy-optionmaster-doc
%description help
# VeighNa框架的期权波动率交易模块

<p align="center">
  <img src ="https://vnpy.oss-cn-shanghai.aliyuncs.com/vnpy-logo.png"/>
</p>

<p align="center">
    <img src ="https://img.shields.io/badge/version-1.0.7-blueviolet.svg"/>
    <img src ="https://img.shields.io/badge/platform-windows|linux|macos-yellow.svg"/>
    <img src ="https://img.shields.io/badge/python-3.7|3.8|3.9|3.10-blue.svg" />
    <img src ="https://img.shields.io/github/license/vnpy/vnpy.svg?color=orange"/>
</p>

## 说明

针对期权波动率交易类策略设计的应用模块,支持波动率曲面实时跟踪、期权组合持仓希腊值风控、Delta自动对冲算法、电子眼波动率执行算法、情景分析压力测试等功能。

## 安装

安装环境推荐基于3.0.0版本以上的【[**VeighNa Studio**](https://www.vnpy.com)】。

直接使用pip命令:

```
pip install vnpy_optionmaster
```


或者下载源代码后,解压后在cmd中运行:

```
pip install .
```


%prep
%autosetup -n vnpy_optionmaster-1.0.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-vnpy-optionmaster -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.7-1
- Package Spec generated