%global _empty_manifest_terminate_build 0
Name: python-yapw
Version: 0.0.13
Release: 1
Summary: A Pika wrapper with error handling, signal handling and good defaults.
License: BSD
URL: https://github.com/open-contracting/yapw
Source0: https://mirrors.aliyun.com/pypi/web/packages/28/77/66d3692ceaafa2249c45be7f37cd6bea0ea731198cc8bce6315a1ca67094/yapw-0.0.13.tar.gz
BuildArch: noarch
Requires: python3-pika
Requires: python3-typing-extensions
Requires: python3-furo
Requires: python3-sphinx
Requires: python3-sphinx-autobuild
Requires: python3-orjson
Requires: python3-coveralls
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-mypy
Requires: python3-types-orjson
Requires: python3-types-pika
%description
|PyPI Version| |Build Status| |Coverage Status| |Python Version|
Yet Another Pika Wrapper (yapw – pronounced yapu) makes it easier to create a `Pika `__ client that has error handling, signal handling, useful logging and good defaults.
(If you are viewing this on GitHub, open the `full documentation `__ for additional details.)
.. |PyPI Version| image:: https://img.shields.io/pypi/v/yapw.svg
:target: https://pypi.org/project/yapw/
.. |Build Status| image:: https://github.com/open-contracting/yapw/workflows/CI/badge.svg
:target: https://github.com/open-contracting/yapw/actions?query=workflow%3ACI
.. |Coverage Status| image:: https://coveralls.io/repos/github/open-contracting/yapw/badge.svg?branch=main
:target: https://coveralls.io/github/open-contracting/yapw?branch=main
.. |Python Version| image:: https://img.shields.io/pypi/pyversions/yapw.svg
:target: https://pypi.org/project/yapw/
%package -n python3-yapw
Summary: A Pika wrapper with error handling, signal handling and good defaults.
Provides: python-yapw
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-yapw
|PyPI Version| |Build Status| |Coverage Status| |Python Version|
Yet Another Pika Wrapper (yapw – pronounced yapu) makes it easier to create a `Pika `__ client that has error handling, signal handling, useful logging and good defaults.
(If you are viewing this on GitHub, open the `full documentation `__ for additional details.)
.. |PyPI Version| image:: https://img.shields.io/pypi/v/yapw.svg
:target: https://pypi.org/project/yapw/
.. |Build Status| image:: https://github.com/open-contracting/yapw/workflows/CI/badge.svg
:target: https://github.com/open-contracting/yapw/actions?query=workflow%3ACI
.. |Coverage Status| image:: https://coveralls.io/repos/github/open-contracting/yapw/badge.svg?branch=main
:target: https://coveralls.io/github/open-contracting/yapw?branch=main
.. |Python Version| image:: https://img.shields.io/pypi/pyversions/yapw.svg
:target: https://pypi.org/project/yapw/
%package help
Summary: Development documents and examples for yapw
Provides: python3-yapw-doc
%description help
|PyPI Version| |Build Status| |Coverage Status| |Python Version|
Yet Another Pika Wrapper (yapw – pronounced yapu) makes it easier to create a `Pika `__ client that has error handling, signal handling, useful logging and good defaults.
(If you are viewing this on GitHub, open the `full documentation `__ for additional details.)
.. |PyPI Version| image:: https://img.shields.io/pypi/v/yapw.svg
:target: https://pypi.org/project/yapw/
.. |Build Status| image:: https://github.com/open-contracting/yapw/workflows/CI/badge.svg
:target: https://github.com/open-contracting/yapw/actions?query=workflow%3ACI
.. |Coverage Status| image:: https://coveralls.io/repos/github/open-contracting/yapw/badge.svg?branch=main
:target: https://coveralls.io/github/open-contracting/yapw?branch=main
.. |Python Version| image:: https://img.shields.io/pypi/pyversions/yapw.svg
:target: https://pypi.org/project/yapw/
%prep
%autosetup -n yapw-0.0.13
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-yapw -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.0.13-1
- Package Spec generated