%global _empty_manifest_terminate_build 0
Name: python-routerling
Version: 0.5.1
Release: 1
Summary: Extremely Stupid Simple, Blazing Fast, Get Out of your way immediately Microframework for building Python Web Applications.
License: MIT
URL: https://pypi.org/project/routerling/
Source0: https://mirrors.aliyun.com/pypi/web/packages/cf/c0/7ed7f5a1cf2bf72d51abf4edfd25634922aa539f583b4779afbfb3c16d67/routerling-0.5.1.tar.gz
BuildArch: noarch
Requires: python3-uvicorn
%description
# Routerling :
Routerling is a very very small, extremely tiny, and insanely fast [ASGI](https://asgi.readthedocs.io) web application framework. It was designed to facilitate productivity by allowing for complete mastery in 7 minutes or less.
Routerling is a very light layer around ASGI with support for application mounting and is perhaps the simplest and one of the fastest python web frameworks (biased opinion of course).
## Installling
Install with [pip](https://pip.pypa.io/en/stable/getting-started/)
```sh
$ pip install routerling
```
## A Simple Example
```py
from routerling import Router
async def index(req, res, ctx):
res.body = 'Hello, World!'
router = Router()
router.GET('/', index)
```
You can run with uvicorn, gunicorn or any other asgi HTTP, HTTP2, and web socket protocol server of your choice.
```sh
$ uvicorn main:router --reload
* Running on http://127.0.0.1:8000
```
## Contributing
For guidance on how to make contributions to Routerling, see the [Contribution Guidelines](contributions.md)
## Links
- Documentation [Go To Docs](https://rayattack.github.io/routerling)
- PyPi [https://pypi.org/project/routerling](https://pypi.org/project/routerling)
- Source Code [Github](https://github.com/rayattack/routerling)
%package -n python3-routerling
Summary: Extremely Stupid Simple, Blazing Fast, Get Out of your way immediately Microframework for building Python Web Applications.
Provides: python-routerling
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-routerling
# Routerling :
Routerling is a very very small, extremely tiny, and insanely fast [ASGI](https://asgi.readthedocs.io) web application framework. It was designed to facilitate productivity by allowing for complete mastery in 7 minutes or less.
Routerling is a very light layer around ASGI with support for application mounting and is perhaps the simplest and one of the fastest python web frameworks (biased opinion of course).
## Installling
Install with [pip](https://pip.pypa.io/en/stable/getting-started/)
```sh
$ pip install routerling
```
## A Simple Example
```py
from routerling import Router
async def index(req, res, ctx):
res.body = 'Hello, World!'
router = Router()
router.GET('/', index)
```
You can run with uvicorn, gunicorn or any other asgi HTTP, HTTP2, and web socket protocol server of your choice.
```sh
$ uvicorn main:router --reload
* Running on http://127.0.0.1:8000
```
## Contributing
For guidance on how to make contributions to Routerling, see the [Contribution Guidelines](contributions.md)
## Links
- Documentation [Go To Docs](https://rayattack.github.io/routerling)
- PyPi [https://pypi.org/project/routerling](https://pypi.org/project/routerling)
- Source Code [Github](https://github.com/rayattack/routerling)
%package help
Summary: Development documents and examples for routerling
Provides: python3-routerling-doc
%description help
# Routerling :
Routerling is a very very small, extremely tiny, and insanely fast [ASGI](https://asgi.readthedocs.io) web application framework. It was designed to facilitate productivity by allowing for complete mastery in 7 minutes or less.
Routerling is a very light layer around ASGI with support for application mounting and is perhaps the simplest and one of the fastest python web frameworks (biased opinion of course).
## Installling
Install with [pip](https://pip.pypa.io/en/stable/getting-started/)
```sh
$ pip install routerling
```
## A Simple Example
```py
from routerling import Router
async def index(req, res, ctx):
res.body = 'Hello, World!'
router = Router()
router.GET('/', index)
```
You can run with uvicorn, gunicorn or any other asgi HTTP, HTTP2, and web socket protocol server of your choice.
```sh
$ uvicorn main:router --reload
* Running on http://127.0.0.1:8000
```
## Contributing
For guidance on how to make contributions to Routerling, see the [Contribution Guidelines](contributions.md)
## Links
- Documentation [Go To Docs](https://rayattack.github.io/routerling)
- PyPi [https://pypi.org/project/routerling](https://pypi.org/project/routerling)
- Source Code [Github](https://github.com/rayattack/routerling)
%prep
%autosetup -n routerling-0.5.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-routerling -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.5.1-1
- Package Spec generated