%global _empty_manifest_terminate_build 0
Name: python-ao3-cli
Version: 0.1.6
Release: 1
Summary: A CLI to download from archiveofourown.org
License: Apache License
URL: https://github.com/arzkar/ao3-cli/
Source0: https://mirrors.aliyun.com/pypi/web/packages/ff/9b/1c926fbde8f818480d81f8bd09a6637e4e0efcfa5acce87a82ed4ee27dd0/ao3-cli-0.1.6.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-rich
Requires: python3-requests
Requires: python3-loguru
Requires: python3-tqdm
Requires: python3-BeautifulSoup4
Requires: python3-colorama
%description
ao3-cli
A CLI to download from archiveofourown.org using their built-in download option.
To report issues for the CLI, open an issue at https://github.com/arzkar/ao3-cli/issues
### Features:
- Download works & series from archiveofourown.org
- It also supports downloading all works or series from any archiveofourown.org page.
# Installation
## Using pip (Recommended)
```
pip install -U ao3-cli
```
## From Source (Might have bugs, for development use)
```
pip install git+https://github.com/arzkar/ao3-cli@main
```
# Usage
```
> ao3_cli
Usage: ao3_cli [OPTIONS]
A CLI to download from archiveofourown.org
To report issues for the CLI, open an issue at
https://github.com/arzkar/ao3-cli/issues
Options:
-u, --url TEXT The url of the fanfiction enclosed within quotes
-i, --infile TEXT Give a filename to read URLs from
-l, --list-url TEXT Enter a comma separated list of urls to download,enclosed within quotes
-o, --out-dir TEXT Absolute path to the Output directory for files(default: Current Directory)
-f, --format TEXT Download Format: EPUB (default), AZW3, MOBI, PDF or HTML
--force Force overwrite of an existing file
--get-urls TEXT Get all story urls found from a page
-d, --debug Show the log in the console for debugging
--log Save the logfile for debugging
-v, --version Display version & quit.
--help Show this message and exit.
```
## Example
- To download using a URL
```
ao3_cli -u https://archiveofourown.org/works/10916730/chapters/24276864
```
- To download using a file containing URLs
```
ao3_cli -i urls.txt
```
- To download using a comma separated list of URLs
```
ao3_cli -l "https://archiveofourown.org/works/31923052/chapters/79053661,https://archiveofourown.org/works/31950595"
```
### Default Configuration
- The fanfiction will be downloaded in epub format. To change it, use `-f` followed by the format.
- The fanfiction will be downloaded in the current directory. To change it, use `-o` followed by the path to the directory.
Check `ao3_cli --help` for more info.
%package -n python3-ao3-cli
Summary: A CLI to download from archiveofourown.org
Provides: python-ao3-cli
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ao3-cli
ao3-cli
A CLI to download from archiveofourown.org using their built-in download option.
To report issues for the CLI, open an issue at https://github.com/arzkar/ao3-cli/issues
### Features:
- Download works & series from archiveofourown.org
- It also supports downloading all works or series from any archiveofourown.org page.
# Installation
## Using pip (Recommended)
```
pip install -U ao3-cli
```
## From Source (Might have bugs, for development use)
```
pip install git+https://github.com/arzkar/ao3-cli@main
```
# Usage
```
> ao3_cli
Usage: ao3_cli [OPTIONS]
A CLI to download from archiveofourown.org
To report issues for the CLI, open an issue at
https://github.com/arzkar/ao3-cli/issues
Options:
-u, --url TEXT The url of the fanfiction enclosed within quotes
-i, --infile TEXT Give a filename to read URLs from
-l, --list-url TEXT Enter a comma separated list of urls to download,enclosed within quotes
-o, --out-dir TEXT Absolute path to the Output directory for files(default: Current Directory)
-f, --format TEXT Download Format: EPUB (default), AZW3, MOBI, PDF or HTML
--force Force overwrite of an existing file
--get-urls TEXT Get all story urls found from a page
-d, --debug Show the log in the console for debugging
--log Save the logfile for debugging
-v, --version Display version & quit.
--help Show this message and exit.
```
## Example
- To download using a URL
```
ao3_cli -u https://archiveofourown.org/works/10916730/chapters/24276864
```
- To download using a file containing URLs
```
ao3_cli -i urls.txt
```
- To download using a comma separated list of URLs
```
ao3_cli -l "https://archiveofourown.org/works/31923052/chapters/79053661,https://archiveofourown.org/works/31950595"
```
### Default Configuration
- The fanfiction will be downloaded in epub format. To change it, use `-f` followed by the format.
- The fanfiction will be downloaded in the current directory. To change it, use `-o` followed by the path to the directory.
Check `ao3_cli --help` for more info.
%package help
Summary: Development documents and examples for ao3-cli
Provides: python3-ao3-cli-doc
%description help
ao3-cli
A CLI to download from archiveofourown.org using their built-in download option.
To report issues for the CLI, open an issue at https://github.com/arzkar/ao3-cli/issues
### Features:
- Download works & series from archiveofourown.org
- It also supports downloading all works or series from any archiveofourown.org page.
# Installation
## Using pip (Recommended)
```
pip install -U ao3-cli
```
## From Source (Might have bugs, for development use)
```
pip install git+https://github.com/arzkar/ao3-cli@main
```
# Usage
```
> ao3_cli
Usage: ao3_cli [OPTIONS]
A CLI to download from archiveofourown.org
To report issues for the CLI, open an issue at
https://github.com/arzkar/ao3-cli/issues
Options:
-u, --url TEXT The url of the fanfiction enclosed within quotes
-i, --infile TEXT Give a filename to read URLs from
-l, --list-url TEXT Enter a comma separated list of urls to download,enclosed within quotes
-o, --out-dir TEXT Absolute path to the Output directory for files(default: Current Directory)
-f, --format TEXT Download Format: EPUB (default), AZW3, MOBI, PDF or HTML
--force Force overwrite of an existing file
--get-urls TEXT Get all story urls found from a page
-d, --debug Show the log in the console for debugging
--log Save the logfile for debugging
-v, --version Display version & quit.
--help Show this message and exit.
```
## Example
- To download using a URL
```
ao3_cli -u https://archiveofourown.org/works/10916730/chapters/24276864
```
- To download using a file containing URLs
```
ao3_cli -i urls.txt
```
- To download using a comma separated list of URLs
```
ao3_cli -l "https://archiveofourown.org/works/31923052/chapters/79053661,https://archiveofourown.org/works/31950595"
```
### Default Configuration
- The fanfiction will be downloaded in epub format. To change it, use `-f` followed by the format.
- The fanfiction will be downloaded in the current directory. To change it, use `-o` followed by the path to the directory.
Check `ao3_cli --help` for more info.
%prep
%autosetup -n ao3-cli-0.1.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ao3-cli -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.6-1
- Package Spec generated