%global _empty_manifest_terminate_build 0
Name:		python-ArgDoc
Version:	0.1.2
Release:	1
Summary:	A package for reducing copy/paste of argument descriptions in docstrings
License:	MIT License
URL:		https://github.com/jsolbrig/argdoc
Source0:	https://mirrors.aliyun.com/pypi/web/packages/ad/64/75263c59de73a5b9c209143aedd47a793ed903be66b496205ec9024c4dec/ArgDoc-0.1.2.tar.gz
BuildArch:	noarch

Requires:	python3-sphinx
Requires:	python3-sphinxcontrib-programoutput

%description
# argdoc
A decorator for reducing copy/paste in docstrings with common arguments and keywords

# Documentation
https://argdoc.readthedocs.io/en/latest/




%package -n python3-ArgDoc
Summary:	A package for reducing copy/paste of argument descriptions in docstrings
Provides:	python-ArgDoc
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ArgDoc
# argdoc
A decorator for reducing copy/paste in docstrings with common arguments and keywords

# Documentation
https://argdoc.readthedocs.io/en/latest/




%package help
Summary:	Development documents and examples for ArgDoc
Provides:	python3-ArgDoc-doc
%description help
# argdoc
A decorator for reducing copy/paste in docstrings with common arguments and keywords

# Documentation
https://argdoc.readthedocs.io/en/latest/




%prep
%autosetup -n ArgDoc-0.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ArgDoc -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.2-1
- Package Spec generated