%global _empty_manifest_terminate_build 0
Name:		python-ashyq
Version:	0.1.0.post3
Release:	1
Summary:	Is a simple and synchronous framework for Private Ashyq API
License:	MIT
URL:		https://github.com/arynyklas/ashyq
Source0:	https://mirrors.aliyun.com/pypi/web/packages/2b/e1/b71528813936e18338658a6b318444907023254396fb2628484642aaeeef/ashyq-0.1.0.post3.tar.gz
BuildArch:	noarch


%description
**ashyq** is a simple and (a-)synchronous framework for Private Ashyq API written in Python 3.7 with `requests <https://github.com/psf/requests>`_ and `aiohttp <https://github.com/aio-libs/aiohttp>`_. It helps you to get your status in Ashyq faster and simpler.

%package -n python3-ashyq
Summary:	Is a simple and synchronous framework for Private Ashyq API
Provides:	python-ashyq
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ashyq
**ashyq** is a simple and (a-)synchronous framework for Private Ashyq API written in Python 3.7 with `requests <https://github.com/psf/requests>`_ and `aiohttp <https://github.com/aio-libs/aiohttp>`_. It helps you to get your status in Ashyq faster and simpler.

%package help
Summary:	Development documents and examples for ashyq
Provides:	python3-ashyq-doc
%description help
**ashyq** is a simple and (a-)synchronous framework for Private Ashyq API written in Python 3.7 with `requests <https://github.com/psf/requests>`_ and `aiohttp <https://github.com/aio-libs/aiohttp>`_. It helps you to get your status in Ashyq faster and simpler.

%prep
%autosetup -n ashyq-0.1.0.post3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ashyq -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0.post3-1
- Package Spec generated