%global _empty_manifest_terminate_build 0
Name:		python-ashes
Version:	19.2.0
Release:	1
Summary:	Lightweight templating for Python (a la dust.js)
License:	BSD
URL:		https://github.com/mahmoud/ashes
Source0:	https://mirrors.aliyun.com/pypi/web/packages/68/ab/cff6fad28ca967c9465c1fd5c44f77616d86a66d2d001460339ba5f35081/ashes-19.2.0.tar.gz
BuildArch:	noarch


%description

Ashes provides a Python implementation of dust_, a lightweight
templating language that makes it easy to create purely data-driven
templates that work equally well on servers and clients.

Ashes is pure Python and is tested on Python 2.7, 3.x, and PyPy.

.. _dust: http://akdubya.github.com/dustjs/



%package -n python3-ashes
Summary:	Lightweight templating for Python (a la dust.js)
Provides:	python-ashes
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ashes

Ashes provides a Python implementation of dust_, a lightweight
templating language that makes it easy to create purely data-driven
templates that work equally well on servers and clients.

Ashes is pure Python and is tested on Python 2.7, 3.x, and PyPy.

.. _dust: http://akdubya.github.com/dustjs/



%package help
Summary:	Development documents and examples for ashes
Provides:	python3-ashes-doc
%description help

Ashes provides a Python implementation of dust_, a lightweight
templating language that makes it easy to create purely data-driven
templates that work equally well on servers and clients.

Ashes is pure Python and is tested on Python 2.7, 3.x, and PyPy.

.. _dust: http://akdubya.github.com/dustjs/



%prep
%autosetup -n ashes-19.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ashes -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 19.2.0-1
- Package Spec generated