%global _empty_manifest_terminate_build 0
Name: python-Commi3
Version: 1.0.7
Release: 1
Summary: Is an Automated Commando Line Tool for pentesting and other fun stuff
License: MIT
URL: https://github.com/VanirLab/commi3
Source0: https://mirrors.aliyun.com/pypi/web/packages/26/40/615ba5550453a2cacd115e615d0ef796d1da575a00aea7da54f6fe7c043a/Commi3-1.0.7.tar.gz
BuildArch: noarch
Requires: python3-colorama
Requires: python3-Jinja2
Requires: python3-dns-lexicon
Requires: python3-bs4
%description
## General Information
**Commi3** (short for [**c**]ryptoanalytic [**o**]ffensive [**m**]ultifunctional [**m**]icrostructure [**i**]njection [**3**] generation 3) is an Automated Commando Line Tool (ACLT)
that can be used from web developers, penetration testers or even security researchers in order to test web-based applications
with the view to find bugs, errors or vulnerabilities related to **[command injection](https://www.owasp.org/index.php/Command_Injection)** attacks.
By using this tool, it is very easy to find and exploit a command injection vulnerability in a certain vulnerable parameter or HTTP/HTTPS header.
## Legal Disclaimer
**With each commi3 run end users are obligated to agree** with the following prelude message:
```
(!) Legal disclaimer: Usage of Commi3 for attacking targets without prior mutual consent is illegal.
It is the end user's responsibility to obey all applicable local, state and federal laws.
Developers assume no liability and are not responsible for any misuse or damage caused by this program.
```
## Requirements
**[Python](http://www.python.org/download/)** version **3.6.x** or **3.7.x** is required for running this program.
## Installation
Download commi3 by cloning the Git repository:
git clone https://github.com/VanirLab/commi3.git commi3
Commi3 comes packaged on the **official repositories** of the following Linux distributions, so you can use the **package manager** to install it!
- [ArchStrike](https://archstrike.org/)
- [BlackArch Linux](http://blackarch.org/)
- [BackBox](https://backbox.org/)
- [Kali Linux](https://www.kali.org/)
- [Parrot Security OS](https://www.parrotsec.org/)
- [Pentoo Linux](https://www.pentoo.ch/)
- [Weakerthan Linux](http://www.weaknetlabs.com/)
Commi3 also comes **as a plugin**, on the following penetration testing frameworks:
- [TrustedSec's Penetration Testers Framework (PTF)](https://github.com/trustedsec/ptf)
- [OWASP Offensive Web Testing Framework (OWTF)](https://github.com/owtf/owtf)
- [CTF-Tools](https://github.com/zardus/ctf-tools)
- [PentestBox](https://tools.pentestbox.com/)
- [PenBox](https://github.com/x3omdax/PenBox)
- [Katoolin](https://github.com/LionSec/katoolin)
- [Aptive's Penetration Testing tools](https://github.com/Aptive/penetration-testing-tools)
- [Homebrew Tap - Pen Test Tools ](https://github.com/sidaf/homebrew-pentest)
## Supported Platforms
- Linux
- Mac OS X
- Windows
## Usage
To get a list of all options and switches use:
python commi3.py -h & python3 commi3.py -h
%package -n python3-Commi3
Summary: Is an Automated Commando Line Tool for pentesting and other fun stuff
Provides: python-Commi3
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Commi3
## General Information
**Commi3** (short for [**c**]ryptoanalytic [**o**]ffensive [**m**]ultifunctional [**m**]icrostructure [**i**]njection [**3**] generation 3) is an Automated Commando Line Tool (ACLT)
that can be used from web developers, penetration testers or even security researchers in order to test web-based applications
with the view to find bugs, errors or vulnerabilities related to **[command injection](https://www.owasp.org/index.php/Command_Injection)** attacks.
By using this tool, it is very easy to find and exploit a command injection vulnerability in a certain vulnerable parameter or HTTP/HTTPS header.
## Legal Disclaimer
**With each commi3 run end users are obligated to agree** with the following prelude message:
```
(!) Legal disclaimer: Usage of Commi3 for attacking targets without prior mutual consent is illegal.
It is the end user's responsibility to obey all applicable local, state and federal laws.
Developers assume no liability and are not responsible for any misuse or damage caused by this program.
```
## Requirements
**[Python](http://www.python.org/download/)** version **3.6.x** or **3.7.x** is required for running this program.
## Installation
Download commi3 by cloning the Git repository:
git clone https://github.com/VanirLab/commi3.git commi3
Commi3 comes packaged on the **official repositories** of the following Linux distributions, so you can use the **package manager** to install it!
- [ArchStrike](https://archstrike.org/)
- [BlackArch Linux](http://blackarch.org/)
- [BackBox](https://backbox.org/)
- [Kali Linux](https://www.kali.org/)
- [Parrot Security OS](https://www.parrotsec.org/)
- [Pentoo Linux](https://www.pentoo.ch/)
- [Weakerthan Linux](http://www.weaknetlabs.com/)
Commi3 also comes **as a plugin**, on the following penetration testing frameworks:
- [TrustedSec's Penetration Testers Framework (PTF)](https://github.com/trustedsec/ptf)
- [OWASP Offensive Web Testing Framework (OWTF)](https://github.com/owtf/owtf)
- [CTF-Tools](https://github.com/zardus/ctf-tools)
- [PentestBox](https://tools.pentestbox.com/)
- [PenBox](https://github.com/x3omdax/PenBox)
- [Katoolin](https://github.com/LionSec/katoolin)
- [Aptive's Penetration Testing tools](https://github.com/Aptive/penetration-testing-tools)
- [Homebrew Tap - Pen Test Tools ](https://github.com/sidaf/homebrew-pentest)
## Supported Platforms
- Linux
- Mac OS X
- Windows
## Usage
To get a list of all options and switches use:
python commi3.py -h & python3 commi3.py -h
%package help
Summary: Development documents and examples for Commi3
Provides: python3-Commi3-doc
%description help
## General Information
**Commi3** (short for [**c**]ryptoanalytic [**o**]ffensive [**m**]ultifunctional [**m**]icrostructure [**i**]njection [**3**] generation 3) is an Automated Commando Line Tool (ACLT)
that can be used from web developers, penetration testers or even security researchers in order to test web-based applications
with the view to find bugs, errors or vulnerabilities related to **[command injection](https://www.owasp.org/index.php/Command_Injection)** attacks.
By using this tool, it is very easy to find and exploit a command injection vulnerability in a certain vulnerable parameter or HTTP/HTTPS header.
## Legal Disclaimer
**With each commi3 run end users are obligated to agree** with the following prelude message:
```
(!) Legal disclaimer: Usage of Commi3 for attacking targets without prior mutual consent is illegal.
It is the end user's responsibility to obey all applicable local, state and federal laws.
Developers assume no liability and are not responsible for any misuse or damage caused by this program.
```
## Requirements
**[Python](http://www.python.org/download/)** version **3.6.x** or **3.7.x** is required for running this program.
## Installation
Download commi3 by cloning the Git repository:
git clone https://github.com/VanirLab/commi3.git commi3
Commi3 comes packaged on the **official repositories** of the following Linux distributions, so you can use the **package manager** to install it!
- [ArchStrike](https://archstrike.org/)
- [BlackArch Linux](http://blackarch.org/)
- [BackBox](https://backbox.org/)
- [Kali Linux](https://www.kali.org/)
- [Parrot Security OS](https://www.parrotsec.org/)
- [Pentoo Linux](https://www.pentoo.ch/)
- [Weakerthan Linux](http://www.weaknetlabs.com/)
Commi3 also comes **as a plugin**, on the following penetration testing frameworks:
- [TrustedSec's Penetration Testers Framework (PTF)](https://github.com/trustedsec/ptf)
- [OWASP Offensive Web Testing Framework (OWTF)](https://github.com/owtf/owtf)
- [CTF-Tools](https://github.com/zardus/ctf-tools)
- [PentestBox](https://tools.pentestbox.com/)
- [PenBox](https://github.com/x3omdax/PenBox)
- [Katoolin](https://github.com/LionSec/katoolin)
- [Aptive's Penetration Testing tools](https://github.com/Aptive/penetration-testing-tools)
- [Homebrew Tap - Pen Test Tools ](https://github.com/sidaf/homebrew-pentest)
## Supported Platforms
- Linux
- Mac OS X
- Windows
## Usage
To get a list of all options and switches use:
python commi3.py -h & python3 commi3.py -h
%prep
%autosetup -n Commi3-1.0.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Commi3 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.7-1
- Package Spec generated