%global _empty_manifest_terminate_build 0
Name: python-pycounter
Version: 2.1.4
Release: 1
Summary: Project COUNTER/NISO SUSHI statistics
License: MIT License
URL: http://www.github.com/pitthsls/pycounter
Source0: https://mirrors.aliyun.com/pypi/web/packages/5b/63/b07d4d788b7e5dbd37aaa871f361ce9a00ace0c4379e08b9ba296ab58281/pycounter-2.1.4.tar.gz
BuildArch: noarch
Requires: python3-openpyxl
Requires: python3-requests
Requires: python3-six
Requires: python3-pendulum
Requires: python3-click
Requires: python3-lxml
Requires: python3-sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-httmock
Requires: python3-mock
Requires: python3-pytest
Requires: python3-coverage
%description
pycounter makes working with `COUNTER `_
usage statistics in Python easy, including fetching statistics with NISO
`SUSHI `_.
A simple command-line client for fetching JR1 reports from SUSHI servers
and outputting them as tab-separated COUNTER 4 reports is included.
Developed by the `Health Sciences Library System `_
of the `University of Pittsburgh `_ to support importing
usage data into our in-house Electronic Resources Management (ERM) system.
Licensed under the `MIT `_ license.
See the file LICENSE for details.
pycounter is tested on Python 2.7, 3.5, 3.6, 3.7 and pypy (2 and 3)
pycounter 2.x will be the last version with support for `Python 2
`_.
Documentation is on `Read the Docs `_ and
the code can be found on `GitHub `_.
%package -n python3-pycounter
Summary: Project COUNTER/NISO SUSHI statistics
Provides: python-pycounter
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pycounter
pycounter makes working with `COUNTER `_
usage statistics in Python easy, including fetching statistics with NISO
`SUSHI `_.
A simple command-line client for fetching JR1 reports from SUSHI servers
and outputting them as tab-separated COUNTER 4 reports is included.
Developed by the `Health Sciences Library System `_
of the `University of Pittsburgh `_ to support importing
usage data into our in-house Electronic Resources Management (ERM) system.
Licensed under the `MIT `_ license.
See the file LICENSE for details.
pycounter is tested on Python 2.7, 3.5, 3.6, 3.7 and pypy (2 and 3)
pycounter 2.x will be the last version with support for `Python 2
`_.
Documentation is on `Read the Docs `_ and
the code can be found on `GitHub `_.
%package help
Summary: Development documents and examples for pycounter
Provides: python3-pycounter-doc
%description help
pycounter makes working with `COUNTER `_
usage statistics in Python easy, including fetching statistics with NISO
`SUSHI `_.
A simple command-line client for fetching JR1 reports from SUSHI servers
and outputting them as tab-separated COUNTER 4 reports is included.
Developed by the `Health Sciences Library System `_
of the `University of Pittsburgh `_ to support importing
usage data into our in-house Electronic Resources Management (ERM) system.
Licensed under the `MIT `_ license.
See the file LICENSE for details.
pycounter is tested on Python 2.7, 3.5, 3.6, 3.7 and pypy (2 and 3)
pycounter 2.x will be the last version with support for `Python 2
`_.
Documentation is on `Read the Docs `_ and
the code can be found on `GitHub `_.
%prep
%autosetup -n pycounter-2.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pycounter -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.1.4-1
- Package Spec generated