%global _empty_manifest_terminate_build 0
Name: python-uber_rides
Version: 0.6.0
Release: 1
Summary: Official Uber API Python SDK
License: MIT
URL: https://github.com/uber/rides-python-sdk
Source0: https://mirrors.aliyun.com/pypi/web/packages/70/73/1d8751d32da910cfb751e7e33fe6dba062560e8fa6467aea43abdee2ae56/uber_rides-0.6.0.tar.gz
BuildArch: noarch
%description
To use the Uber Rides Python SDK:
$ pip install uber_rides
Head over to `pip-installer `_ for instructions on installing pip.
To run from source, you can `download the source code `_ for uber-rides, and then run:
$ python setup.py install
We recommend using `virtualenv `_ when setting up your project environment. You may need to run the above commands with `sudo` if you’re not using it.
%package -n python3-uber_rides
Summary: Official Uber API Python SDK
Provides: python-uber_rides
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-uber_rides
To use the Uber Rides Python SDK:
$ pip install uber_rides
Head over to `pip-installer `_ for instructions on installing pip.
To run from source, you can `download the source code `_ for uber-rides, and then run:
$ python setup.py install
We recommend using `virtualenv `_ when setting up your project environment. You may need to run the above commands with `sudo` if you’re not using it.
%package help
Summary: Development documents and examples for uber_rides
Provides: python3-uber_rides-doc
%description help
To use the Uber Rides Python SDK:
$ pip install uber_rides
Head over to `pip-installer `_ for instructions on installing pip.
To run from source, you can `download the source code `_ for uber-rides, and then run:
$ python setup.py install
We recommend using `virtualenv `_ when setting up your project environment. You may need to run the above commands with `sudo` if you’re not using it.
%prep
%autosetup -n uber_rides-0.6.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-uber_rides -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.6.0-1
- Package Spec generated