%global _empty_manifest_terminate_build 0
Name: python-StructuralGT
Version: 1.0.1b1
Release: 1
Summary: Automated graph theory analysis of digital structural networks images
License: GNU General Public License v3
URL: https://github.com/drewvecchio/StructuralGT
Source0: https://mirrors.aliyun.com/pypi/web/packages/31/e2/f2cdfa1dd73ecb83cc212514ecb1a75a70565305f0020ad10910751ecf18/StructuralGT-1.0.1b1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-scikit-image
Requires: python3-matplotlib
Requires: python3-networkx
Requires: python3-opencv-python
Requires: python3-sknw
Requires: python3-Pillow
Requires: python3-pandas
%description
StructuralGT: An automated python package for graph theory analysis of structural networks.
Designed for processing digital micrographs of complex network materials.
For example, analyzing SEM images of polymer network.
StructuralGT is designed as an easy-to-use python-based application for applying graph theory (GT) analysis to
structural networks of a wide variety of material systems. This application converts digital images of
nano-/micro-/macro-scale structures into a GT representation of the structure in the image
consisting of nodes and the edges that connect them. Fibers (or fiber-like structures) are taken to represent edges,
and the location where a fiber branches, or 2 or more fibers intersect are taken to represent nodes. The program
operates with a graphical user interface (GUI) so that selecting images and processing the graphs are intuitive and
accessible to anyone, regardless of programming experience. Detection of networks from input images, the extraction of
the graph object, and the subsequent GT analysis of the graph is handled entirely from the GUI, and a PDF file with the
results of the analysis is saved. Also see StructuralGT_RC for added Ricci Curvature analysis.
See the README for detail information.
https://github.com/drewvecchio/StructuralGT
Copyright (C) 2021, The Regents of the University of Michigan.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
Contributers: Drew Vecchio, Samuel Mahler, Mark D. Hammig, Nicholas A. Kotov
Contact email: vecdrew@umich.edu
%package -n python3-StructuralGT
Summary: Automated graph theory analysis of digital structural networks images
Provides: python-StructuralGT
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-StructuralGT
StructuralGT: An automated python package for graph theory analysis of structural networks.
Designed for processing digital micrographs of complex network materials.
For example, analyzing SEM images of polymer network.
StructuralGT is designed as an easy-to-use python-based application for applying graph theory (GT) analysis to
structural networks of a wide variety of material systems. This application converts digital images of
nano-/micro-/macro-scale structures into a GT representation of the structure in the image
consisting of nodes and the edges that connect them. Fibers (or fiber-like structures) are taken to represent edges,
and the location where a fiber branches, or 2 or more fibers intersect are taken to represent nodes. The program
operates with a graphical user interface (GUI) so that selecting images and processing the graphs are intuitive and
accessible to anyone, regardless of programming experience. Detection of networks from input images, the extraction of
the graph object, and the subsequent GT analysis of the graph is handled entirely from the GUI, and a PDF file with the
results of the analysis is saved. Also see StructuralGT_RC for added Ricci Curvature analysis.
See the README for detail information.
https://github.com/drewvecchio/StructuralGT
Copyright (C) 2021, The Regents of the University of Michigan.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
Contributers: Drew Vecchio, Samuel Mahler, Mark D. Hammig, Nicholas A. Kotov
Contact email: vecdrew@umich.edu
%package help
Summary: Development documents and examples for StructuralGT
Provides: python3-StructuralGT-doc
%description help
StructuralGT: An automated python package for graph theory analysis of structural networks.
Designed for processing digital micrographs of complex network materials.
For example, analyzing SEM images of polymer network.
StructuralGT is designed as an easy-to-use python-based application for applying graph theory (GT) analysis to
structural networks of a wide variety of material systems. This application converts digital images of
nano-/micro-/macro-scale structures into a GT representation of the structure in the image
consisting of nodes and the edges that connect them. Fibers (or fiber-like structures) are taken to represent edges,
and the location where a fiber branches, or 2 or more fibers intersect are taken to represent nodes. The program
operates with a graphical user interface (GUI) so that selecting images and processing the graphs are intuitive and
accessible to anyone, regardless of programming experience. Detection of networks from input images, the extraction of
the graph object, and the subsequent GT analysis of the graph is handled entirely from the GUI, and a PDF file with the
results of the analysis is saved. Also see StructuralGT_RC for added Ricci Curvature analysis.
See the README for detail information.
https://github.com/drewvecchio/StructuralGT
Copyright (C) 2021, The Regents of the University of Michigan.
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
Contributers: Drew Vecchio, Samuel Mahler, Mark D. Hammig, Nicholas A. Kotov
Contact email: vecdrew@umich.edu
%prep
%autosetup -n StructuralGT-1.0.1b1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-StructuralGT -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.1b1-1
- Package Spec generated