%global _empty_manifest_terminate_build 0
Name: python-BlurWal
Version: 1.1.1
Release: 1
Summary: Smoothly blurs the wallpaper when windows are opened.
License: MIT
URL: https://gitlab.com/BVollmerhaus/blurwal
Source0: https://mirrors.aliyun.com/pypi/web/packages/90/ac/e2fa1183438e218c22ffbbe1d8a4140b124d63a4d11c972baa1afb7a3b2e/BlurWal-1.1.1.tar.gz
BuildArch: noarch
Requires: python3-xlib
%description
# BlurWal
BlurWal smoothly blurs the wallpaper when a given number of windows is opened
on the focused workspace. This is done by first generating transition frames
from the current wallpaper, with each of them being blurred with an increasing
level. Upon opening enough windows, each frame will be set as the wallpaper in
quick succession, resulting in a transition. When the number of open windows
goes below the threshold again, the transition will run in reverse and
consequently unblur the wallpaper.
## Table of Contents
* [Installation](#installation)
* [Dependencies](#dependencies)
* [Supported Backends](#supported-backends)
* [Stable Release](#stable-release)
* [Development Version](#development-version)
* [Usage](#usage)
* [Multi-monitor Setups](#multi-monitor-setups)
* [Contributors](#contributors)
* [License](#license)
## Installation
### Dependencies
* `Python 3.6+`
* `ImageMagick` (for generating transition frames)
* A compatible backend, depending on your environment
### Supported Backends
| Name in [CLI](#cli) | Command used | Environment | Availability |
| ------------------- | ------------ | ----------- | ------------ |
| `feh` | `feh` | **Most WMs** (i3, awesome, bspwm, Openbox, etc.) | Separate package
| `xfce` | `xfconf-query` | **Xfce** (uses xfconf to [store wallpaper configuration](https://git.xfce.org/xfce/xfdesktop/tree/doc/README.xfconf#n1)) | Part of Xfce
### Stable Release
```sh
pip install --user blurwal
```
> Also [available in the Arch User Repository](https://aur.archlinux.org/packages/blurwal/) as `blurwal`
>
> Installing from the AUR is preferred, as BlurWal will be updated together
> with the rest of your system.
### Development Version
```sh
git clone https://gitlab.com/BVollmerhaus/blurwal
cd blurwal
pip install --user .
```
> The latest changes on master, which may not be as stable.
## Usage
Simply run `blurwal` and it will regenerate its transition frames and blur
on the appropriate window events.
### CLI
This list includes only the interesting options – run `blurwal -h` for a
complete list and further information.
| Option | Description |
| ------ | ----------- |
| `-m`, `--min` | The minimum number of windows to blur the wallpaper (default: 2)
| `-s`, `--steps` | The number of steps in a blur transition (default: 10, minimum: 2)
| `-b`, `--blur` | The blur strength (sigma) to use when fully blurred (default: 10)
| `-i`, `--ignore` | A space-separated list of window classes to exclude
| `--backend` | The backend to use (one of the [compatible backends](#supported-backends))
## Multi-monitor Setups
Multi-monitor configurations are only partially supported. Depending on the
backend, BlurWal will use the wallpaper of your primary monitor (and first
workspace) and apply it to all monitors, only taking the focused workspace and
the number of windows on it into account. This also means that using different
wallpapers per individual monitor is not possible, as all will be overwritten
with the primary one.
> Changing this behavior is planned but will require some major changes.
## Contributors
### Maintainer
* [Benedikt Vollmerhaus](https://gitlab.com/BVollmerhaus)
### Others
* [Matthias Bräuer](https://gitlab.com/Braeuer) (Testing and Code Reviews)
## License
BlurWal is licensed under the MIT license. See
[LICENSE](https://gitlab.com/BVollmerhaus/blurwal/blob/master/LICENSE)
for more information.
%package -n python3-BlurWal
Summary: Smoothly blurs the wallpaper when windows are opened.
Provides: python-BlurWal
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-BlurWal
# BlurWal
BlurWal smoothly blurs the wallpaper when a given number of windows is opened
on the focused workspace. This is done by first generating transition frames
from the current wallpaper, with each of them being blurred with an increasing
level. Upon opening enough windows, each frame will be set as the wallpaper in
quick succession, resulting in a transition. When the number of open windows
goes below the threshold again, the transition will run in reverse and
consequently unblur the wallpaper.
## Table of Contents
* [Installation](#installation)
* [Dependencies](#dependencies)
* [Supported Backends](#supported-backends)
* [Stable Release](#stable-release)
* [Development Version](#development-version)
* [Usage](#usage)
* [Multi-monitor Setups](#multi-monitor-setups)
* [Contributors](#contributors)
* [License](#license)
## Installation
### Dependencies
* `Python 3.6+`
* `ImageMagick` (for generating transition frames)
* A compatible backend, depending on your environment
### Supported Backends
| Name in [CLI](#cli) | Command used | Environment | Availability |
| ------------------- | ------------ | ----------- | ------------ |
| `feh` | `feh` | **Most WMs** (i3, awesome, bspwm, Openbox, etc.) | Separate package
| `xfce` | `xfconf-query` | **Xfce** (uses xfconf to [store wallpaper configuration](https://git.xfce.org/xfce/xfdesktop/tree/doc/README.xfconf#n1)) | Part of Xfce
### Stable Release
```sh
pip install --user blurwal
```
> Also [available in the Arch User Repository](https://aur.archlinux.org/packages/blurwal/) as `blurwal`
>
> Installing from the AUR is preferred, as BlurWal will be updated together
> with the rest of your system.
### Development Version
```sh
git clone https://gitlab.com/BVollmerhaus/blurwal
cd blurwal
pip install --user .
```
> The latest changes on master, which may not be as stable.
## Usage
Simply run `blurwal` and it will regenerate its transition frames and blur
on the appropriate window events.
### CLI
This list includes only the interesting options – run `blurwal -h` for a
complete list and further information.
| Option | Description |
| ------ | ----------- |
| `-m`, `--min` | The minimum number of windows to blur the wallpaper (default: 2)
| `-s`, `--steps` | The number of steps in a blur transition (default: 10, minimum: 2)
| `-b`, `--blur` | The blur strength (sigma) to use when fully blurred (default: 10)
| `-i`, `--ignore` | A space-separated list of window classes to exclude
| `--backend` | The backend to use (one of the [compatible backends](#supported-backends))
## Multi-monitor Setups
Multi-monitor configurations are only partially supported. Depending on the
backend, BlurWal will use the wallpaper of your primary monitor (and first
workspace) and apply it to all monitors, only taking the focused workspace and
the number of windows on it into account. This also means that using different
wallpapers per individual monitor is not possible, as all will be overwritten
with the primary one.
> Changing this behavior is planned but will require some major changes.
## Contributors
### Maintainer
* [Benedikt Vollmerhaus](https://gitlab.com/BVollmerhaus)
### Others
* [Matthias Bräuer](https://gitlab.com/Braeuer) (Testing and Code Reviews)
## License
BlurWal is licensed under the MIT license. See
[LICENSE](https://gitlab.com/BVollmerhaus/blurwal/blob/master/LICENSE)
for more information.
%package help
Summary: Development documents and examples for BlurWal
Provides: python3-BlurWal-doc
%description help
# BlurWal
BlurWal smoothly blurs the wallpaper when a given number of windows is opened
on the focused workspace. This is done by first generating transition frames
from the current wallpaper, with each of them being blurred with an increasing
level. Upon opening enough windows, each frame will be set as the wallpaper in
quick succession, resulting in a transition. When the number of open windows
goes below the threshold again, the transition will run in reverse and
consequently unblur the wallpaper.
## Table of Contents
* [Installation](#installation)
* [Dependencies](#dependencies)
* [Supported Backends](#supported-backends)
* [Stable Release](#stable-release)
* [Development Version](#development-version)
* [Usage](#usage)
* [Multi-monitor Setups](#multi-monitor-setups)
* [Contributors](#contributors)
* [License](#license)
## Installation
### Dependencies
* `Python 3.6+`
* `ImageMagick` (for generating transition frames)
* A compatible backend, depending on your environment
### Supported Backends
| Name in [CLI](#cli) | Command used | Environment | Availability |
| ------------------- | ------------ | ----------- | ------------ |
| `feh` | `feh` | **Most WMs** (i3, awesome, bspwm, Openbox, etc.) | Separate package
| `xfce` | `xfconf-query` | **Xfce** (uses xfconf to [store wallpaper configuration](https://git.xfce.org/xfce/xfdesktop/tree/doc/README.xfconf#n1)) | Part of Xfce
### Stable Release
```sh
pip install --user blurwal
```
> Also [available in the Arch User Repository](https://aur.archlinux.org/packages/blurwal/) as `blurwal`
>
> Installing from the AUR is preferred, as BlurWal will be updated together
> with the rest of your system.
### Development Version
```sh
git clone https://gitlab.com/BVollmerhaus/blurwal
cd blurwal
pip install --user .
```
> The latest changes on master, which may not be as stable.
## Usage
Simply run `blurwal` and it will regenerate its transition frames and blur
on the appropriate window events.
### CLI
This list includes only the interesting options – run `blurwal -h` for a
complete list and further information.
| Option | Description |
| ------ | ----------- |
| `-m`, `--min` | The minimum number of windows to blur the wallpaper (default: 2)
| `-s`, `--steps` | The number of steps in a blur transition (default: 10, minimum: 2)
| `-b`, `--blur` | The blur strength (sigma) to use when fully blurred (default: 10)
| `-i`, `--ignore` | A space-separated list of window classes to exclude
| `--backend` | The backend to use (one of the [compatible backends](#supported-backends))
## Multi-monitor Setups
Multi-monitor configurations are only partially supported. Depending on the
backend, BlurWal will use the wallpaper of your primary monitor (and first
workspace) and apply it to all monitors, only taking the focused workspace and
the number of windows on it into account. This also means that using different
wallpapers per individual monitor is not possible, as all will be overwritten
with the primary one.
> Changing this behavior is planned but will require some major changes.
## Contributors
### Maintainer
* [Benedikt Vollmerhaus](https://gitlab.com/BVollmerhaus)
### Others
* [Matthias Bräuer](https://gitlab.com/Braeuer) (Testing and Code Reviews)
## License
BlurWal is licensed under the MIT license. See
[LICENSE](https://gitlab.com/BVollmerhaus/blurwal/blob/master/LICENSE)
for more information.
%prep
%autosetup -n BlurWal-1.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-BlurWal -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.1.1-1
- Package Spec generated