%global _empty_manifest_terminate_build 0
Name: python-flinit
Version: 0.2.4
Release: 1
Summary: Flask App Initializer.
License: MIT
URL: https://github.com/TanmoySG/flinit
Source0: https://mirrors.aliyun.com/pypi/web/packages/2b/8a/8a7d184f992560ce68087fe68f22622619b6ac00e38493fe7a00196b5827/flinit-0.2.4.tar.gz
BuildArch: noarch
Requires: python3-pip
Requires: python3-emoji
%description
# flinit
Flinit ( **fl**ask **init** ) is a Python Command-Line Tool to Initialize a Python-Flask Project with Boilerplate Code and other required tools.
Flinit is a create-react-app like tool for Flask Projects.
## Features
- Creates Project Working Directory
- Spins up a Python Virtual Environment
- Generates Flask App File, app.py
- Installs Flask and CORS (optional)
- Adds Flask and CORS Helper Methods
- Adds Boilerplate Code to app.py
- Generates initial environment requirments file
- Adds README.md to the project
- Generates .gitignore for Python Project
- Initializes Git for Project.
# Usage
Flinit can be used on any system with Python and PIP installed and **PIP added to the OS Environment Path**.
## Installation
Flinit can be installed using Pip.
```
pip install flinit
```
## Using Flinit to Create a Flask Project
After installing flinit using pip, goto any CLI and use the flinit command to setup the Flask App.
```
flinit [projectName] [location] -g -r -c
flinit [projectName] [location] -gt -rd -cr
flinit [projectName] [location] --git --readme --cors
```
projectName - The Name of the Project.
location - Path where Project is to be setup.
**Flags**
-h or --help - Provides Instruction about how to use Flinit.
-g or -gt or --git - Flag to add git to project. If this flag is used, git will be initialized for the project.
-r or -rd or --readme - Flag to add README.md to project. If this flag is used, a README file is generated.
-c or -cr or --cors - Flag to install and CORS to project. If this flag is used, CORS is installed and added a helper method is added to the app.py file.
%package -n python3-flinit
Summary: Flask App Initializer.
Provides: python-flinit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flinit
# flinit
Flinit ( **fl**ask **init** ) is a Python Command-Line Tool to Initialize a Python-Flask Project with Boilerplate Code and other required tools.
Flinit is a create-react-app like tool for Flask Projects.
## Features
- Creates Project Working Directory
- Spins up a Python Virtual Environment
- Generates Flask App File, app.py
- Installs Flask and CORS (optional)
- Adds Flask and CORS Helper Methods
- Adds Boilerplate Code to app.py
- Generates initial environment requirments file
- Adds README.md to the project
- Generates .gitignore for Python Project
- Initializes Git for Project.
# Usage
Flinit can be used on any system with Python and PIP installed and **PIP added to the OS Environment Path**.
## Installation
Flinit can be installed using Pip.
```
pip install flinit
```
## Using Flinit to Create a Flask Project
After installing flinit using pip, goto any CLI and use the flinit command to setup the Flask App.
```
flinit [projectName] [location] -g -r -c
flinit [projectName] [location] -gt -rd -cr
flinit [projectName] [location] --git --readme --cors
```
projectName - The Name of the Project.
location - Path where Project is to be setup.
**Flags**
-h or --help - Provides Instruction about how to use Flinit.
-g or -gt or --git - Flag to add git to project. If this flag is used, git will be initialized for the project.
-r or -rd or --readme - Flag to add README.md to project. If this flag is used, a README file is generated.
-c or -cr or --cors - Flag to install and CORS to project. If this flag is used, CORS is installed and added a helper method is added to the app.py file.
%package help
Summary: Development documents and examples for flinit
Provides: python3-flinit-doc
%description help
# flinit
Flinit ( **fl**ask **init** ) is a Python Command-Line Tool to Initialize a Python-Flask Project with Boilerplate Code and other required tools.
Flinit is a create-react-app like tool for Flask Projects.
## Features
- Creates Project Working Directory
- Spins up a Python Virtual Environment
- Generates Flask App File, app.py
- Installs Flask and CORS (optional)
- Adds Flask and CORS Helper Methods
- Adds Boilerplate Code to app.py
- Generates initial environment requirments file
- Adds README.md to the project
- Generates .gitignore for Python Project
- Initializes Git for Project.
# Usage
Flinit can be used on any system with Python and PIP installed and **PIP added to the OS Environment Path**.
## Installation
Flinit can be installed using Pip.
```
pip install flinit
```
## Using Flinit to Create a Flask Project
After installing flinit using pip, goto any CLI and use the flinit command to setup the Flask App.
```
flinit [projectName] [location] -g -r -c
flinit [projectName] [location] -gt -rd -cr
flinit [projectName] [location] --git --readme --cors
```
projectName - The Name of the Project.
location - Path where Project is to be setup.
**Flags**
-h or --help - Provides Instruction about how to use Flinit.
-g or -gt or --git - Flag to add git to project. If this flag is used, git will be initialized for the project.
-r or -rd or --readme - Flag to add README.md to project. If this flag is used, a README file is generated.
-c or -cr or --cors - Flag to install and CORS to project. If this flag is used, CORS is installed and added a helper method is added to the app.py file.
%prep
%autosetup -n flinit-0.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flinit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.2.4-1
- Package Spec generated