%global _empty_manifest_terminate_build 0
Name: python-OpenQuestion
Version: 0.1.1
Release: 1
Summary: An open source survey platform written in Python.
License: BSD 3-clause
URL: https://github.com/Alcampopiano/OpenQuestion
Source0: https://mirrors.aliyun.com/pypi/web/packages/3d/37/7e39fca5f2cfb555ff9da1b1de5d06a7e8eb6a2126df091a55b6e7db510a/OpenQuestion-0.1.1.tar.gz
BuildArch: noarch
Requires: python3-pandas
Requires: python3-numpy
Requires: python3-anvil-app-server
Requires: python3-mistune
Requires: python3-anvil-uplink
Requires: python3-bcrypt
%description
# OpenQuestion
[](https://pypi.org/project/OpenQuestion/)
[](https://pypistats.org/packages/OpenQuestion)
[](https://github.com/Alcampopiano/OpenQuestion/blob/master/LICENSE)
OpenQuestion is a survey building and reporting platform written in Python.
Surveys can be developed using a GUI or by writing Python code. To report on
survey results, OpenQuestion provides a Jupyter-like environment
for data visualization and document creation.
## Documentation
:book: Please visit the [OpenQuestion documentation site](https://Alcampopiano.github.io/OpenQuestion/).
## Develop surveys with a GUI

## Surveys are stored as a Python dictionary/JSON
```python
my_survey={
"title": "simple survey",
"settings": {
"survey_color": "#2196F3",
"thank_you_msg": "#Thank you!"
},
"num_widgets": 2,
"widgets": [
{
"id": 0,
"type": "section",
"logic": None,
"title": "section",
"widgets": [
{
"id": 1,
"type": "text_box",
"logic": None,
"title": "what's your name?",
"number": False,
"mandatory": True,
"placeholder": "placeholder here"
}
]
}
]
}
```
## Citing OpenQuestion
... coming soon
%package -n python3-OpenQuestion
Summary: An open source survey platform written in Python.
Provides: python-OpenQuestion
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-OpenQuestion
# OpenQuestion
[](https://pypi.org/project/OpenQuestion/)
[](https://pypistats.org/packages/OpenQuestion)
[](https://github.com/Alcampopiano/OpenQuestion/blob/master/LICENSE)
OpenQuestion is a survey building and reporting platform written in Python.
Surveys can be developed using a GUI or by writing Python code. To report on
survey results, OpenQuestion provides a Jupyter-like environment
for data visualization and document creation.
## Documentation
:book: Please visit the [OpenQuestion documentation site](https://Alcampopiano.github.io/OpenQuestion/).
## Develop surveys with a GUI

## Surveys are stored as a Python dictionary/JSON
```python
my_survey={
"title": "simple survey",
"settings": {
"survey_color": "#2196F3",
"thank_you_msg": "#Thank you!"
},
"num_widgets": 2,
"widgets": [
{
"id": 0,
"type": "section",
"logic": None,
"title": "section",
"widgets": [
{
"id": 1,
"type": "text_box",
"logic": None,
"title": "what's your name?",
"number": False,
"mandatory": True,
"placeholder": "placeholder here"
}
]
}
]
}
```
## Citing OpenQuestion
... coming soon
%package help
Summary: Development documents and examples for OpenQuestion
Provides: python3-OpenQuestion-doc
%description help
# OpenQuestion
[](https://pypi.org/project/OpenQuestion/)
[](https://pypistats.org/packages/OpenQuestion)
[](https://github.com/Alcampopiano/OpenQuestion/blob/master/LICENSE)
OpenQuestion is a survey building and reporting platform written in Python.
Surveys can be developed using a GUI or by writing Python code. To report on
survey results, OpenQuestion provides a Jupyter-like environment
for data visualization and document creation.
## Documentation
:book: Please visit the [OpenQuestion documentation site](https://Alcampopiano.github.io/OpenQuestion/).
## Develop surveys with a GUI

## Surveys are stored as a Python dictionary/JSON
```python
my_survey={
"title": "simple survey",
"settings": {
"survey_color": "#2196F3",
"thank_you_msg": "#Thank you!"
},
"num_widgets": 2,
"widgets": [
{
"id": 0,
"type": "section",
"logic": None,
"title": "section",
"widgets": [
{
"id": 1,
"type": "text_box",
"logic": None,
"title": "what's your name?",
"number": False,
"mandatory": True,
"placeholder": "placeholder here"
}
]
}
]
}
```
## Citing OpenQuestion
... coming soon
%prep
%autosetup -n OpenQuestion-0.1.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-OpenQuestion -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.1-1
- Package Spec generated