%global _empty_manifest_terminate_build 0 Name: python-load Version: 2020.12.3 Release: 1 Summary: load python module from a file License: Unlicense URL: https://github.com/andrewp-as-is/load.py Source0: https://mirrors.aliyun.com/pypi/web/packages/93/c2/f48f768d9930e13b808e8f22e4b1b6b6626e10ebbedc520c8085d109823e/load-2020.12.3.tar.gz BuildArch: noarch %description [![](https://img.shields.io/pypi/v/load.svg?maxAge=3600)](https://pypi.org/project/load/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install load ``` #### Features + python 2/3 compatible #### Examples ```python >>> import load >>> load.load('name','path.py') ```

readme42.com

%package -n python3-load Summary: load python module from a file Provides: python-load BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-load [![](https://img.shields.io/pypi/v/load.svg?maxAge=3600)](https://pypi.org/project/load/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install load ``` #### Features + python 2/3 compatible #### Examples ```python >>> import load >>> load.load('name','path.py') ```

readme42.com

%package help Summary: Development documents and examples for load Provides: python3-load-doc %description help [![](https://img.shields.io/pypi/v/load.svg?maxAge=3600)](https://pypi.org/project/load/) [![](https://img.shields.io/badge/License-Unlicense-blue.svg?longCache=True)](https://unlicense.org/) ### Installation ```bash $ [sudo] pip install load ``` #### Features + python 2/3 compatible #### Examples ```python >>> import load >>> load.load('name','path.py') ```

readme42.com

%prep %autosetup -n load-2020.12.3 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-load -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 2020.12.3-1 - Package Spec generated