%global _empty_manifest_terminate_build 0
Name: python-PyWebScraper
Version: 0.1.5
Release: 1
Summary: A web scraper that combines both Beautiful Soup (bs4) and Selenium.
License: MIT License
URL: https://github.com/glowingkitty/PyWebScraper
Source0: https://mirrors.aliyun.com/pypi/web/packages/59/83/e2abdc5ea9f56d77b37dc8473b130799ddf117e6b63dc0360d4d3dff8592/PyWebScraper-0.1.5.tar.gz
BuildArch: noarch
Requires: python3-bs4
Requires: python3-requests
Requires: python3-selenium
%description

A web scraper that combines both Beautiful Soup (bs4) and Selenium.
Want to support the development and stay updated?
## Installation
```
pip install PyWebScraper
```
## Usage
```
from PyWebScraper import Scraper
```
Scraper() will load bs4 or selenium (defined with the input 'scraper_type') to then load a website (defined by the input 'url') and save it under Scraper().page.
Optional inputs for Scraper():
```
url = str (will be opened in scraper and page saved in Scraper().page)
scraper_type = 'bs4' or 'selenium'
scroll_down = boolean (scrolls down in selenium first before saving page)
user_agent = 'desktop' or 'mobile'
auto_close_selenium = boolean (if False, you can further interact with the selenium browser via Scraper().selenium)
selenium_remote_webdriver = str (IP for a remote webdriver for selenium, see https://www.selenium.dev/docs/site/en/remote_webdriver/remote_webdriver_client/)
```
%package -n python3-PyWebScraper
Summary: A web scraper that combines both Beautiful Soup (bs4) and Selenium.
Provides: python-PyWebScraper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyWebScraper

A web scraper that combines both Beautiful Soup (bs4) and Selenium.
Want to support the development and stay updated?
## Installation
```
pip install PyWebScraper
```
## Usage
```
from PyWebScraper import Scraper
```
Scraper() will load bs4 or selenium (defined with the input 'scraper_type') to then load a website (defined by the input 'url') and save it under Scraper().page.
Optional inputs for Scraper():
```
url = str (will be opened in scraper and page saved in Scraper().page)
scraper_type = 'bs4' or 'selenium'
scroll_down = boolean (scrolls down in selenium first before saving page)
user_agent = 'desktop' or 'mobile'
auto_close_selenium = boolean (if False, you can further interact with the selenium browser via Scraper().selenium)
selenium_remote_webdriver = str (IP for a remote webdriver for selenium, see https://www.selenium.dev/docs/site/en/remote_webdriver/remote_webdriver_client/)
```
%package help
Summary: Development documents and examples for PyWebScraper
Provides: python3-PyWebScraper-doc
%description help

A web scraper that combines both Beautiful Soup (bs4) and Selenium.
Want to support the development and stay updated?
## Installation
```
pip install PyWebScraper
```
## Usage
```
from PyWebScraper import Scraper
```
Scraper() will load bs4 or selenium (defined with the input 'scraper_type') to then load a website (defined by the input 'url') and save it under Scraper().page.
Optional inputs for Scraper():
```
url = str (will be opened in scraper and page saved in Scraper().page)
scraper_type = 'bs4' or 'selenium'
scroll_down = boolean (scrolls down in selenium first before saving page)
user_agent = 'desktop' or 'mobile'
auto_close_selenium = boolean (if False, you can further interact with the selenium browser via Scraper().selenium)
selenium_remote_webdriver = str (IP for a remote webdriver for selenium, see https://www.selenium.dev/docs/site/en/remote_webdriver/remote_webdriver_client/)
```
%prep
%autosetup -n PyWebScraper-0.1.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyWebScraper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 0.1.5-1
- Package Spec generated