%global _empty_manifest_terminate_build 0
Name: python-mopidy-raspberry-gpio
Version: 1.0.4
Release: 1
Summary: Mopidy extension for GPIO input on a Raspberry Pi
License: Apache License, Version 2.0
URL: https://github.com/pimoroni/mopidy-raspberry-gpio
Source0: https://mirrors.aliyun.com/pypi/web/packages/16/3e/4a703ff641124c6287e1114fba2b9b98f41278d6b54f448d8f2e2dcd25cf/mopidy-raspberry-gpio-1.0.4.tar.gz
BuildArch: noarch
Requires: python3-Mopidy
Requires: python3-Pykka
Requires: python3-setuptools
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-flake8-import-order
Requires: python3-isort[pyproject]
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-twine
Requires: python3-wheel
Requires: python3-black
Requires: python3-check-manifest
Requires: python3-flake8
Requires: python3-flake8-bugbear
Requires: python3-flake8-import-order
Requires: python3-isort[pyproject]
Requires: python3-twine
Requires: python3-wheel
Requires: python3-pytest
Requires: python3-pytest-cov
%description
Ensure Mopidy has access to GPIO::
sudo usermod -a -G gpio mopidy
Make sure you have the RPi.GPIO library installed::
sudo apt install python3-rpi.gpio
Install by running::
python3 -m pip install Mopidy-Raspberry-GPIO
Or, if available, install the Debian/Ubuntu package from `apt.mopidy.com
`_.
%package -n python3-mopidy-raspberry-gpio
Summary: Mopidy extension for GPIO input on a Raspberry Pi
Provides: python-mopidy-raspberry-gpio
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-mopidy-raspberry-gpio
Ensure Mopidy has access to GPIO::
sudo usermod -a -G gpio mopidy
Make sure you have the RPi.GPIO library installed::
sudo apt install python3-rpi.gpio
Install by running::
python3 -m pip install Mopidy-Raspberry-GPIO
Or, if available, install the Debian/Ubuntu package from `apt.mopidy.com
`_.
%package help
Summary: Development documents and examples for mopidy-raspberry-gpio
Provides: python3-mopidy-raspberry-gpio-doc
%description help
Ensure Mopidy has access to GPIO::
sudo usermod -a -G gpio mopidy
Make sure you have the RPi.GPIO library installed::
sudo apt install python3-rpi.gpio
Install by running::
python3 -m pip install Mopidy-Raspberry-GPIO
Or, if available, install the Debian/Ubuntu package from `apt.mopidy.com
`_.
%prep
%autosetup -n mopidy-raspberry-gpio-1.0.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-mopidy-raspberry-gpio -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 1.0.4-1
- Package Spec generated