%global _empty_manifest_terminate_build 0
Name: python-PyRKHSstats
Version: 2.1.0
Release: 1
Summary: A Python package for kernel methods in Statistics/ML.
License: GNU General Public License v3.0
URL: https://github.com/Black-Swan-ICL/PyRKHSstats
Source0: https://mirrors.aliyun.com/pypi/web/packages/68/7f/01cf21d15ef653abdd9c7bb00fb772467c8618cf19ba38944f833c4f224b/PyRKHSstats-2.1.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-pandas
Requires: python3-scikit-learn
Requires: python3-GPy
Requires: python3-pyyaml
%description
# PyRKHSstats
A Python package implementing a variety of statistical/machine learning methods
that rely on kernels (e.g. HSIC for independence testing).
## Overview
- Independence testing with HSIC (Hilbert-Schmidt Independence Criterion), as
introduced in
[A Kernel Statistical Test of Independence](https://papers.nips.cc/paper/2007/hash/d5cfead94f5350c12c322b5b664544c1-Abstract.html),
A. Gretton, K. Fukumizu, C. Hui Teo, L. Song, B. Schölkopf, and A.
Smola (NIPS 2007).
- Measurement of conditional independence with HSCIC (Hilbert-Schmidt
Conditional Independence Criterion), as introduced in
[A Measure-Theoretic Approach to Kernel Conditional Mean Embeddings](https://papers.nips.cc/paper/2020/hash/f340f1b1f65b6df5b5e3f94d95b11daf-Abstract.html),
J. Park and K. Muandet (NeurIPS 2020).
- The Kernel-based Conditional Independence Test (KCIT), as introduced in
[Kernel-based Conditional Independence Test and Application in Causal
Discovery](https://arxiv.org/abs/1202.3775), K. Zhang, J. Peters, D. Janzing,
B. Schölkopf (UAI 2011).
- Two-sample testing (also known as homogeneity testing) with the MMD
(Maximum Mean Discrepancy), as presented in [A Fast, Consistent Kernel
Two-Sample Test](https://papers.nips.cc/paper/2009/hash/9246444d94f081e3549803b928260f56-Abstract.html),
A. Gretton, K. Fukumizu, Z. Harchaoui, and B. K. Sriperumbudur (NIPS 2009)
and in [A Kernel Two-Sample Test](https://jmlr.org/papers/v13/gretton12a.html),
A. Gretton, K. M. Borgwardt, M. J. Rasch, B. Schölkopf, and A. Smola
(JMLR, volume 13, 2012).
| Resource | Description |
| :--- | :--- |
| HSIC | For independence testing |
| HSCIC | For the measurement of conditional independence |
| KCIT | For conditional independence testing |
| MMD | For two-sample testing |
## Implementations available
The following table details the implementation schemes for the different
resources available in the package.
| Resource | Implementation Scheme | Numpy based available | PyTorch based available |
| :--- | :--- | :----: |:----: |
| HSIC | Resampling (permuting the xi's but leaving the yi's unchanged) | Yes | No |
| HSIC | Gamma approximation | Yes | No |
| HSCIC | N/A | Yes | Yes |
| KCIT | Gamma approximation | Yes | No |
| KCIT | Monte Carlo simulation (weighted sum of χ2 random variables)| Yes | No |
| MMD | Gram matrix spectrum | Yes | No |
[comment]: <> (| MMD | Permutation | Yes | No |)
## In development
- Joint independence testing with dHSIC.
- Goodness-of-fit testing.
- Methods for time series models.
- Bayesian statistical kernel methods.
- Regression by independence maximisation.
%package -n python3-PyRKHSstats
Summary: A Python package for kernel methods in Statistics/ML.
Provides: python-PyRKHSstats
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PyRKHSstats
# PyRKHSstats
A Python package implementing a variety of statistical/machine learning methods
that rely on kernels (e.g. HSIC for independence testing).
## Overview
- Independence testing with HSIC (Hilbert-Schmidt Independence Criterion), as
introduced in
[A Kernel Statistical Test of Independence](https://papers.nips.cc/paper/2007/hash/d5cfead94f5350c12c322b5b664544c1-Abstract.html),
A. Gretton, K. Fukumizu, C. Hui Teo, L. Song, B. Schölkopf, and A.
Smola (NIPS 2007).
- Measurement of conditional independence with HSCIC (Hilbert-Schmidt
Conditional Independence Criterion), as introduced in
[A Measure-Theoretic Approach to Kernel Conditional Mean Embeddings](https://papers.nips.cc/paper/2020/hash/f340f1b1f65b6df5b5e3f94d95b11daf-Abstract.html),
J. Park and K. Muandet (NeurIPS 2020).
- The Kernel-based Conditional Independence Test (KCIT), as introduced in
[Kernel-based Conditional Independence Test and Application in Causal
Discovery](https://arxiv.org/abs/1202.3775), K. Zhang, J. Peters, D. Janzing,
B. Schölkopf (UAI 2011).
- Two-sample testing (also known as homogeneity testing) with the MMD
(Maximum Mean Discrepancy), as presented in [A Fast, Consistent Kernel
Two-Sample Test](https://papers.nips.cc/paper/2009/hash/9246444d94f081e3549803b928260f56-Abstract.html),
A. Gretton, K. Fukumizu, Z. Harchaoui, and B. K. Sriperumbudur (NIPS 2009)
and in [A Kernel Two-Sample Test](https://jmlr.org/papers/v13/gretton12a.html),
A. Gretton, K. M. Borgwardt, M. J. Rasch, B. Schölkopf, and A. Smola
(JMLR, volume 13, 2012).
| Resource | Description |
| :--- | :--- |
| HSIC | For independence testing |
| HSCIC | For the measurement of conditional independence |
| KCIT | For conditional independence testing |
| MMD | For two-sample testing |
## Implementations available
The following table details the implementation schemes for the different
resources available in the package.
| Resource | Implementation Scheme | Numpy based available | PyTorch based available |
| :--- | :--- | :----: |:----: |
| HSIC | Resampling (permuting the xi's but leaving the yi's unchanged) | Yes | No |
| HSIC | Gamma approximation | Yes | No |
| HSCIC | N/A | Yes | Yes |
| KCIT | Gamma approximation | Yes | No |
| KCIT | Monte Carlo simulation (weighted sum of χ2 random variables)| Yes | No |
| MMD | Gram matrix spectrum | Yes | No |
[comment]: <> (| MMD | Permutation | Yes | No |)
## In development
- Joint independence testing with dHSIC.
- Goodness-of-fit testing.
- Methods for time series models.
- Bayesian statistical kernel methods.
- Regression by independence maximisation.
%package help
Summary: Development documents and examples for PyRKHSstats
Provides: python3-PyRKHSstats-doc
%description help
# PyRKHSstats
A Python package implementing a variety of statistical/machine learning methods
that rely on kernels (e.g. HSIC for independence testing).
## Overview
- Independence testing with HSIC (Hilbert-Schmidt Independence Criterion), as
introduced in
[A Kernel Statistical Test of Independence](https://papers.nips.cc/paper/2007/hash/d5cfead94f5350c12c322b5b664544c1-Abstract.html),
A. Gretton, K. Fukumizu, C. Hui Teo, L. Song, B. Schölkopf, and A.
Smola (NIPS 2007).
- Measurement of conditional independence with HSCIC (Hilbert-Schmidt
Conditional Independence Criterion), as introduced in
[A Measure-Theoretic Approach to Kernel Conditional Mean Embeddings](https://papers.nips.cc/paper/2020/hash/f340f1b1f65b6df5b5e3f94d95b11daf-Abstract.html),
J. Park and K. Muandet (NeurIPS 2020).
- The Kernel-based Conditional Independence Test (KCIT), as introduced in
[Kernel-based Conditional Independence Test and Application in Causal
Discovery](https://arxiv.org/abs/1202.3775), K. Zhang, J. Peters, D. Janzing,
B. Schölkopf (UAI 2011).
- Two-sample testing (also known as homogeneity testing) with the MMD
(Maximum Mean Discrepancy), as presented in [A Fast, Consistent Kernel
Two-Sample Test](https://papers.nips.cc/paper/2009/hash/9246444d94f081e3549803b928260f56-Abstract.html),
A. Gretton, K. Fukumizu, Z. Harchaoui, and B. K. Sriperumbudur (NIPS 2009)
and in [A Kernel Two-Sample Test](https://jmlr.org/papers/v13/gretton12a.html),
A. Gretton, K. M. Borgwardt, M. J. Rasch, B. Schölkopf, and A. Smola
(JMLR, volume 13, 2012).
| Resource | Description |
| :--- | :--- |
| HSIC | For independence testing |
| HSCIC | For the measurement of conditional independence |
| KCIT | For conditional independence testing |
| MMD | For two-sample testing |
## Implementations available
The following table details the implementation schemes for the different
resources available in the package.
| Resource | Implementation Scheme | Numpy based available | PyTorch based available |
| :--- | :--- | :----: |:----: |
| HSIC | Resampling (permuting the xi's but leaving the yi's unchanged) | Yes | No |
| HSIC | Gamma approximation | Yes | No |
| HSCIC | N/A | Yes | Yes |
| KCIT | Gamma approximation | Yes | No |
| KCIT | Monte Carlo simulation (weighted sum of χ2 random variables)| Yes | No |
| MMD | Gram matrix spectrum | Yes | No |
[comment]: <> (| MMD | Permutation | Yes | No |)
## In development
- Joint independence testing with dHSIC.
- Goodness-of-fit testing.
- Methods for time series models.
- Bayesian statistical kernel methods.
- Regression by independence maximisation.
%prep
%autosetup -n PyRKHSstats-2.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PyRKHSstats -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Jun 20 2023 Python_Bot - 2.1.0-1
- Package Spec generated