%global _empty_manifest_terminate_build 0
Name:		python-oidcrp
Version:	2.1.4
Release:	1
Summary:	Python implementation of OAuth2 Client and OpenID Connect RP
License:	Apache 2.0
URL:		https://github.com/IdentityPython/oicrp/
Source0:	https://mirrors.aliyun.com/pypi/web/packages/7e/04/21c7be3b5f6adf0fe21de9f87379e75e16eaeb33a7d1fe591302883f55e6/oidcrp-2.1.4.tar.gz
BuildArch:	noarch

Requires:	python3-oidcmsg
Requires:	python3-pyyaml
Requires:	python3-responses

%description
# oidcrp

![CI build](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/workflows/oidcrp/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcrp.svg)
[![Downloads total](https://pepy.tech/badge/oidcrp)](https://pepy.tech/project/oidcrp)
[![Downloads week](https://pepy.tech/badge/oidcrp/week)](https://pepy.tech/project/oidcrp)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)
![Documentation Status](https://readthedocs.org/projects/oidcrp/badge/?version=latest)
![Python version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9-blue.svg)


High level interface to the OIDC RP library

oidcrp represents the 3rd layer in the JWTConnect stack (cryptojwt, oidcmsg, oidcrp)

See the documentation at http://oidcrp.readthedocs.io/en/latest/ .

See sample RPs in [example/](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/tree/master/example) folder.

![OIDC Certification mark](doc/source/_images/oid-l-certification-mark-l-rgb-150dpi-90mm-300x157.png)




%package -n python3-oidcrp
Summary:	Python implementation of OAuth2 Client and OpenID Connect RP
Provides:	python-oidcrp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-oidcrp
# oidcrp

![CI build](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/workflows/oidcrp/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcrp.svg)
[![Downloads total](https://pepy.tech/badge/oidcrp)](https://pepy.tech/project/oidcrp)
[![Downloads week](https://pepy.tech/badge/oidcrp/week)](https://pepy.tech/project/oidcrp)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)
![Documentation Status](https://readthedocs.org/projects/oidcrp/badge/?version=latest)
![Python version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9-blue.svg)


High level interface to the OIDC RP library

oidcrp represents the 3rd layer in the JWTConnect stack (cryptojwt, oidcmsg, oidcrp)

See the documentation at http://oidcrp.readthedocs.io/en/latest/ .

See sample RPs in [example/](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/tree/master/example) folder.

![OIDC Certification mark](doc/source/_images/oid-l-certification-mark-l-rgb-150dpi-90mm-300x157.png)




%package help
Summary:	Development documents and examples for oidcrp
Provides:	python3-oidcrp-doc
%description help
# oidcrp

![CI build](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/workflows/oidcrp/badge.svg)
![pypi](https://img.shields.io/pypi/v/oidcrp.svg)
[![Downloads total](https://pepy.tech/badge/oidcrp)](https://pepy.tech/project/oidcrp)
[![Downloads week](https://pepy.tech/badge/oidcrp/week)](https://pepy.tech/project/oidcrp)
![License](https://img.shields.io/badge/license-Apache%202-blue.svg)
![Documentation Status](https://readthedocs.org/projects/oidcrp/badge/?version=latest)
![Python version](https://img.shields.io/badge/python-3.7%20%7C%203.8%20%7C%203.9-blue.svg)


High level interface to the OIDC RP library

oidcrp represents the 3rd layer in the JWTConnect stack (cryptojwt, oidcmsg, oidcrp)

See the documentation at http://oidcrp.readthedocs.io/en/latest/ .

See sample RPs in [example/](https://github.com/IdentityPython/JWTConnect-Python-OidcRP/tree/master/example) folder.

![OIDC Certification mark](doc/source/_images/oid-l-certification-mark-l-rgb-150dpi-90mm-300x157.png)




%prep
%autosetup -n oidcrp-2.1.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-oidcrp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.4-1
- Package Spec generated