%global _empty_manifest_terminate_build 0 Name: python-http-status-code Version: 0.0.11 Release: 1 Summary: This module contains a simple library with a single class to define HTTP status codes License: MIT URL: https://github.com/Quakingaspen-codehub/http_status_code Source0: https://mirrors.aliyun.com/pypi/web/packages/14/5b/4bfff8c8c7bb3b42639e6db8a2337eb2b21aff1e9e41a3d5a54ce61e96f9/http-status-code-0.0.11.tar.gz BuildArch: noarch %description
# http-status-code [Introduction](#Introduction)\ [Getting Started](#Started)\ [Example](#Example)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This module contains a simple library with a single class to define HTTP status codes

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http_status_code ``` The following status codes are available in the standard module: General: - Successful request: 200 - Bad request: 400 - You are not authorized: 403 - The required resource is not found: 404 - Request arguments (query string or body) validation error: 410 Authentication - Invalid credentials: 430 - Your account is inactive: 431 - Missing token: 432 - The token is invalid: 433 - The token is expired: 434 - Wrong token error (related to refresh and access tokens) 435 - You have logged out invalid credentials. Please log in again: 436 Database - This record already exists: 630 - This record is related to other records. Therefore, it cannot be deleted: 631

Example

In order to use refer to the following [example](https://github.com/Quakingaspen-codehub/http_status_code/blob/master/Example.ipynb)

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package -n python3-http-status-code Summary: This module contains a simple library with a single class to define HTTP status codes Provides: python-http-status-code BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-http-status-code
# http-status-code [Introduction](#Introduction)\ [Getting Started](#Started)\ [Example](#Example)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This module contains a simple library with a single class to define HTTP status codes

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http_status_code ``` The following status codes are available in the standard module: General: - Successful request: 200 - Bad request: 400 - You are not authorized: 403 - The required resource is not found: 404 - Request arguments (query string or body) validation error: 410 Authentication - Invalid credentials: 430 - Your account is inactive: 431 - Missing token: 432 - The token is invalid: 433 - The token is expired: 434 - Wrong token error (related to refresh and access tokens) 435 - You have logged out invalid credentials. Please log in again: 436 Database - This record already exists: 630 - This record is related to other records. Therefore, it cannot be deleted: 631

Example

In order to use refer to the following [example](https://github.com/Quakingaspen-codehub/http_status_code/blob/master/Example.ipynb)

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %package help Summary: Development documents and examples for http-status-code Provides: python3-http-status-code-doc %description help
# http-status-code [Introduction](#Introduction)\ [Getting Started](#Started)\ [Example](#Example)\ [Contributors](#Contributors)\ [License](#License)

Introduction

This module contains a simple library with a single class to define HTTP status codes

Getting Started

In order to install, open the command prompt and type ✌️: ``` pip install http_status_code ``` The following status codes are available in the standard module: General: - Successful request: 200 - Bad request: 400 - You are not authorized: 403 - The required resource is not found: 404 - Request arguments (query string or body) validation error: 410 Authentication - Invalid credentials: 430 - Your account is inactive: 431 - Missing token: 432 - The token is invalid: 433 - The token is expired: 434 - Wrong token error (related to refresh and access tokens) 435 - You have logged out invalid credentials. Please log in again: 436 Database - This record already exists: 630 - This record is related to other records. Therefore, it cannot be deleted: 631

Example

In order to use refer to the following [example](https://github.com/Quakingaspen-codehub/http_status_code/blob/master/Example.ipynb)

Contributors

This project exists thanks to all the people who contribute. [[Contribute](CONTRIBUTING.md)]. ""

License

This library is licensed under the MIT License - see the [LICENSE.md](LICENSE) file for details. %prep %autosetup -n http-status-code-0.0.11 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-http-status-code -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Tue Jun 20 2023 Python_Bot - 0.0.11-1 - Package Spec generated