%global _empty_manifest_terminate_build 0
Name: python-aioesphomeapi
Version: 13.5.0
Release: 1
Summary: Python API for interacting with ESPHome devices.
License: MIT
URL: https://esphome.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0e/ba/ef43e009ae0a1f759ebb5fdc2e59253538ae80c13017e3cfa4ad7b81df82/aioesphomeapi-13.5.0.tar.gz
BuildArch: noarch
Requires: python3-protobuf
Requires: python3-zeroconf
Requires: python3-noiseprotocol
Requires: python3-async-timeout
%description
``aioesphomeapi`` allows you to interact with devices flashed with `ESPHome `_.
%package -n python3-aioesphomeapi
Summary: Python API for interacting with ESPHome devices.
Provides: python-aioesphomeapi
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-aioesphomeapi
``aioesphomeapi`` allows you to interact with devices flashed with `ESPHome `_.
%package help
Summary: Development documents and examples for aioesphomeapi
Provides: python3-aioesphomeapi-doc
%description help
``aioesphomeapi`` allows you to interact with devices flashed with `ESPHome `_.
%prep
%autosetup -n aioesphomeapi-13.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-aioesphomeapi -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Mar 07 2023 Python_Bot - 13.5.0-1
- Package Spec generated