%global _empty_manifest_terminate_build 0
Name:		python-opencensus-ext-requests
Version:	0.8.0
Release:	1
Summary:	OpenCensus Requests Integration
License:	Apache-2.0
URL:		https://github.com/census-instrumentation/opencensus-python/tree/master/contrib/opencensus-ext-requests
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b3/35/9072d30ad34fe845aae31046d33beb660470b059e69b652d893e0e9c947f/opencensus-ext-requests-0.8.0.tar.gz
BuildArch:	noarch

Requires:	python3-opencensus
Requires:	python3-requests
Requires:	python3-wrapt

%description
|pypi|
OpenCensus can trace HTTP requests made with the `requests package`_. The request URL,
method, and status will be collected.
You can enable requests integration by specifying ``'requests'`` to ``trace_integrations``.
It's possible to configure a list of URL you don't want traced. By default the request to exporter
won't be traced. It's configurable by giving an array of hostname/port to the attribute
``excludelist_hostnames`` in OpenCensus context's attributes:
Only the hostname must be specified if only the hostname is specified in the URL request.

%package -n python3-opencensus-ext-requests
Summary:	OpenCensus Requests Integration
Provides:	python-opencensus-ext-requests
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-opencensus-ext-requests
|pypi|
OpenCensus can trace HTTP requests made with the `requests package`_. The request URL,
method, and status will be collected.
You can enable requests integration by specifying ``'requests'`` to ``trace_integrations``.
It's possible to configure a list of URL you don't want traced. By default the request to exporter
won't be traced. It's configurable by giving an array of hostname/port to the attribute
``excludelist_hostnames`` in OpenCensus context's attributes:
Only the hostname must be specified if only the hostname is specified in the URL request.

%package help
Summary:	Development documents and examples for opencensus-ext-requests
Provides:	python3-opencensus-ext-requests-doc
%description help
|pypi|
OpenCensus can trace HTTP requests made with the `requests package`_. The request URL,
method, and status will be collected.
You can enable requests integration by specifying ``'requests'`` to ``trace_integrations``.
It's possible to configure a list of URL you don't want traced. By default the request to exporter
won't be traced. It's configurable by giving an array of hostname/port to the attribute
``excludelist_hostnames`` in OpenCensus context's attributes:
Only the hostname must be specified if only the hostname is specified in the URL request.

%prep
%autosetup -n opencensus-ext-requests-0.8.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-opencensus-ext-requests -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.0-1
- Package Spec generated