%global _empty_manifest_terminate_build 0
Name: python-patsy
Version: 0.5.3
Release: 1
Summary: A Python package for describing statistical models and for building design matrices.
License: 2-clause BSD
URL: https://github.com/pydata/patsy
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/93/3b7db0bb8f1143f8ddb84f931719e7a538e3092c6898e5cdf65e1ed44fcb/patsy-0.5.3.tar.gz
BuildArch: noarch
Requires: python3-six
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-scipy
%description
Patsy is a Python library for describing statistical models
(especially linear models, or models that have a linear component) and
building design matrices. Patsy brings the convenience of [R](http://www.r-project.org/) "formulas" to Python.
[![PyPI - Version](https://img.shields.io/pypi/v/patsy.svg)](https://pypi.org/project/spec-classes/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/patsy.svg)
![https://patsy.readthedocs.io/](https://img.shields.io/badge/docs-read%20now-blue.svg)
![PyPI - Status](https://img.shields.io/pypi/status/patsy.svg)
![https://travis-ci.org/pydata/patsy](https://travis-ci.org/pydata/patsy.png?branch=master)
![https://coveralls.io/r/pydata/patsy?branch=master](https://coveralls.io/repos/pydata/patsy/badge.png?branch=master)
![https://doi.org/10.5281/zenodo.592075](https://zenodo.org/badge/DOI/10.5281/zenodo.592075.svg)
- **Documentation:**
- **Downloads:**
- **Code and issues:**
- **Mailing list:** ()
## Dependencies
* Python (2.6, 2.7, or 3.3+)
* six
* numpy
* Optional:
* pytest/pytest-cov: needed to run tests
* scipy: needed for spline-related functions like ``bs``
## Installation
``pip install patsy`` (or, for traditionalists: ``python setup.py install``)
## License
2-clause BSD, see LICENSE.txt for details.
%package -n python3-patsy
Summary: A Python package for describing statistical models and for building design matrices.
Provides: python-patsy
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-patsy
Patsy is a Python library for describing statistical models
(especially linear models, or models that have a linear component) and
building design matrices. Patsy brings the convenience of [R](http://www.r-project.org/) "formulas" to Python.
[![PyPI - Version](https://img.shields.io/pypi/v/patsy.svg)](https://pypi.org/project/spec-classes/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/patsy.svg)
![https://patsy.readthedocs.io/](https://img.shields.io/badge/docs-read%20now-blue.svg)
![PyPI - Status](https://img.shields.io/pypi/status/patsy.svg)
![https://travis-ci.org/pydata/patsy](https://travis-ci.org/pydata/patsy.png?branch=master)
![https://coveralls.io/r/pydata/patsy?branch=master](https://coveralls.io/repos/pydata/patsy/badge.png?branch=master)
![https://doi.org/10.5281/zenodo.592075](https://zenodo.org/badge/DOI/10.5281/zenodo.592075.svg)
- **Documentation:**
- **Downloads:**
- **Code and issues:**
- **Mailing list:** ()
## Dependencies
* Python (2.6, 2.7, or 3.3+)
* six
* numpy
* Optional:
* pytest/pytest-cov: needed to run tests
* scipy: needed for spline-related functions like ``bs``
## Installation
``pip install patsy`` (or, for traditionalists: ``python setup.py install``)
## License
2-clause BSD, see LICENSE.txt for details.
%package help
Summary: Development documents and examples for patsy
Provides: python3-patsy-doc
%description help
Patsy is a Python library for describing statistical models
(especially linear models, or models that have a linear component) and
building design matrices. Patsy brings the convenience of [R](http://www.r-project.org/) "formulas" to Python.
[![PyPI - Version](https://img.shields.io/pypi/v/patsy.svg)](https://pypi.org/project/spec-classes/)
![PyPI - Python Version](https://img.shields.io/pypi/pyversions/patsy.svg)
![https://patsy.readthedocs.io/](https://img.shields.io/badge/docs-read%20now-blue.svg)
![PyPI - Status](https://img.shields.io/pypi/status/patsy.svg)
![https://travis-ci.org/pydata/patsy](https://travis-ci.org/pydata/patsy.png?branch=master)
![https://coveralls.io/r/pydata/patsy?branch=master](https://coveralls.io/repos/pydata/patsy/badge.png?branch=master)
![https://doi.org/10.5281/zenodo.592075](https://zenodo.org/badge/DOI/10.5281/zenodo.592075.svg)
- **Documentation:**
- **Downloads:**
- **Code and issues:**
- **Mailing list:** ()
## Dependencies
* Python (2.6, 2.7, or 3.3+)
* six
* numpy
* Optional:
* pytest/pytest-cov: needed to run tests
* scipy: needed for spline-related functions like ``bs``
## Installation
``pip install patsy`` (or, for traditionalists: ``python setup.py install``)
## License
2-clause BSD, see LICENSE.txt for details.
%prep
%autosetup -n patsy-0.5.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-patsy -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.5.3-1
- Package Spec generated