%global _empty_manifest_terminate_build 0
Name: python-pymatreader
Version: 0.0.30
Release: 1
Summary: Convenient reader for Matlab mat files
License: BSD (2 clause)
URL: https://gitlab.com/obob/pymatreader
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f2/41/327c79de0c4bb6e382e9fda384936c7da5b7f8cc71e1ce19fdeae389db34/pymatreader-0.0.30.tar.gz
BuildArch: noarch
Requires: python3-h5py
Requires: python3-scipy
Requires: python3-numpy
Requires: python3-xmltodict
Requires: python3-future
%description
# pymatreader
A Python module to read Matlab files. This module works with both the old (< 7.3) and the new (>= 7.3) HDF5 based format. The output should be the same for both kinds of files.
## How to use
```python
from pymatreader import read_mat
data = read_mat(filename)
```
`data` is a python `dict` containing all variables of the mat file.
## Documentation
Documentation can be found here:
## Code
The source code can be found here:
## License
This module is developed by Dirk Gütlin & Thomas Hartmann at the Universität Salzburg. You are free to use, copy, modify, distribute it under the terms of the BSD 2 clause license.
%package -n python3-pymatreader
Summary: Convenient reader for Matlab mat files
Provides: python-pymatreader
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pymatreader
# pymatreader
A Python module to read Matlab files. This module works with both the old (< 7.3) and the new (>= 7.3) HDF5 based format. The output should be the same for both kinds of files.
## How to use
```python
from pymatreader import read_mat
data = read_mat(filename)
```
`data` is a python `dict` containing all variables of the mat file.
## Documentation
Documentation can be found here:
## Code
The source code can be found here:
## License
This module is developed by Dirk Gütlin & Thomas Hartmann at the Universität Salzburg. You are free to use, copy, modify, distribute it under the terms of the BSD 2 clause license.
%package help
Summary: Development documents and examples for pymatreader
Provides: python3-pymatreader-doc
%description help
# pymatreader
A Python module to read Matlab files. This module works with both the old (< 7.3) and the new (>= 7.3) HDF5 based format. The output should be the same for both kinds of files.
## How to use
```python
from pymatreader import read_mat
data = read_mat(filename)
```
`data` is a python `dict` containing all variables of the mat file.
## Documentation
Documentation can be found here:
## Code
The source code can be found here:
## License
This module is developed by Dirk Gütlin & Thomas Hartmann at the Universität Salzburg. You are free to use, copy, modify, distribute it under the terms of the BSD 2 clause license.
%prep
%autosetup -n pymatreader-0.0.30
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pymatreader -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 0.0.30-1
- Package Spec generated