%global _empty_manifest_terminate_build 0
Name:		python-pypcapkit
Version:	0.16.3
Release:	1
Summary:	Python multi-engine PCAP analyse kit.
License:	BSD 3-Clause License
URL:		https://github.com/JarryShaw/PyPCAPKit
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6b/94/9fda6e55a79f9b3e43a04f061943abccae12dfd31610b1b354e24d1af3ca/pypcapkit-0.16.3.tar.gz
BuildArch:	noarch

Requires:	python3-dictdumper
Requires:	python3-chardet
Requires:	python3-aenum
Requires:	python3-tbtrim
Requires:	python3-dpkt
Requires:	python3-pyshark
Requires:	python3-scapy
Requires:	python3-emoji
Requires:	python3-dpkt
Requires:	python3-scapy
Requires:	python3-pyshark
Requires:	python3-requests[socks]
Requires:	python3-beautifulsoup4[html5lib]
Requires:	python3-emoji
Requires:	python3-requests[socks]
Requires:	python3-beautifulsoup4[html5lib]

%description
   For any technical and/or maintenance information,
   please kindly refer to the |docs|_.
The PyPCAPKit project is an open source Python program focus
on `PCAP`_ parsing and analysis, which works as a stream PCAP file extractor.
With support of `DictDumper`_, it shall support multiple
output report formats.

%package -n python3-pypcapkit
Summary:	Python multi-engine PCAP analyse kit.
Provides:	python-pypcapkit
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pypcapkit
   For any technical and/or maintenance information,
   please kindly refer to the |docs|_.
The PyPCAPKit project is an open source Python program focus
on `PCAP`_ parsing and analysis, which works as a stream PCAP file extractor.
With support of `DictDumper`_, it shall support multiple
output report formats.

%package help
Summary:	Development documents and examples for pypcapkit
Provides:	python3-pypcapkit-doc
%description help
   For any technical and/or maintenance information,
   please kindly refer to the |docs|_.
The PyPCAPKit project is an open source Python program focus
on `PCAP`_ parsing and analysis, which works as a stream PCAP file extractor.
With support of `DictDumper`_, it shall support multiple
output report formats.

%prep
%autosetup -n pypcapkit-0.16.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pypcapkit -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.16.3-1
- Package Spec generated