%global _empty_manifest_terminate_build 0
Name:		python-setuptools-lint
Version:	0.6.0
Release:	1
Summary:	Setuptools command for pylint
License:	BSD
URL:		https://github.com/johnnoone/setuptools-pylint
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7a/31/2c82e3ec44a9b281c844b660c08d2c8405f692fe7fdde058766c4cfb3fc4/setuptools-lint-0.6.0.tar.gz
BuildArch:	noarch

Requires:	python3-pylint

%description
This package expose `pylint`_ as a lint command into setup.py.

%package -n python3-setuptools-lint
Summary:	Setuptools command for pylint
Provides:	python-setuptools-lint
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-setuptools-lint
This package expose `pylint`_ as a lint command into setup.py.

%package help
Summary:	Development documents and examples for setuptools-lint
Provides:	python3-setuptools-lint-doc
%description help
This package expose `pylint`_ as a lint command into setup.py.

%prep
%autosetup -n setuptools-lint-0.6.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-setuptools-lint -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
- Package Spec generated