%global _empty_manifest_terminate_build 0
Name: python-SQLObject
Version: 3.10.1
Release: 1
Summary: Object-Relational Manager, aka database wrapper
License: LGPL
URL: http://sqlobject.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/42/87/1fe25439876567ffc839f4324cdfec5595f5b710c80758c6e44193df3be4/SQLObject-3.10.1.tar.gz
BuildArch: noarch
Requires: python3-PyDispatcher
Requires: python3-FormEncode
Requires: python3-FormEncode
Requires: python3-adodbapi
Requires: python3-fdb
Requires: python3-firebirdsql
Requires: python3-kinterbasdb
Requires: python3-mariadb
Requires: python3-mysql-connector
Requires: python3-mysql-connector-python
Requires: python3-MySQL-python
Requires: python3-mysqlclient
Requires: python3-pyodbc
Requires: python3-oursql
Requires: python3-oursql3
Requires: python3-pg8000
Requires: python3-pg8000
Requires: python3-pg8000
Requires: python3-psycopg2
Requires: python3-psycopg2
Requires: python3-psycopg2
Requires: python3-psycopg2
Requires: python3-py-postgresql
Requires: python3-pygresql
Requires: python3-pymssql
Requires: python3-pymysql
Requires: python3-pyodbc
Requires: python3-py-postgresql
Requires: python3-pypyodbc
Requires: python3-sapdb
Requires: python3-pysqlite
Requires: python3-supersqlite
Requires: python3-Sybase
%description
SQLObject is a popular *Object Relational Manager* for providing an
object interface to your database, with tables as classes, rows as
instances, and columns as attributes.
SQLObject includes a Python-object-based query language that makes SQL
more abstract, and provides substantial database independence for
applications.
Supports MySQL, PostgreSQL, SQLite, Firebird, Sybase, MSSQL and MaxDB (SAPDB).
Python 2.7 or 3.4+ is required.
For development see the projects at
`SourceForge `_
and `GitHub `_.
.. image:: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml/badge.svg?branch=github-actions
:target: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml
%package -n python3-SQLObject
Summary: Object-Relational Manager, aka database wrapper
Provides: python-SQLObject
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-SQLObject
SQLObject is a popular *Object Relational Manager* for providing an
object interface to your database, with tables as classes, rows as
instances, and columns as attributes.
SQLObject includes a Python-object-based query language that makes SQL
more abstract, and provides substantial database independence for
applications.
Supports MySQL, PostgreSQL, SQLite, Firebird, Sybase, MSSQL and MaxDB (SAPDB).
Python 2.7 or 3.4+ is required.
For development see the projects at
`SourceForge `_
and `GitHub `_.
.. image:: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml/badge.svg?branch=github-actions
:target: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml
%package help
Summary: Development documents and examples for SQLObject
Provides: python3-SQLObject-doc
%description help
SQLObject is a popular *Object Relational Manager* for providing an
object interface to your database, with tables as classes, rows as
instances, and columns as attributes.
SQLObject includes a Python-object-based query language that makes SQL
more abstract, and provides substantial database independence for
applications.
Supports MySQL, PostgreSQL, SQLite, Firebird, Sybase, MSSQL and MaxDB (SAPDB).
Python 2.7 or 3.4+ is required.
For development see the projects at
`SourceForge `_
and `GitHub `_.
.. image:: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml/badge.svg?branch=github-actions
:target: https://github.com/sqlobject/sqlobject/actions/workflows/run-tests.yaml
%prep
%autosetup -n SQLObject-3.10.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-SQLObject -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 3.10.1-1
- Package Spec generated