%global _empty_manifest_terminate_build 0
Name: python-visidata
Version: 2.11
Release: 1
Summary: terminal interface for exploring and arranging tabular data
License: GPLv3
URL: https://visidata.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/45/75bec1b89ec27b0e74f84da2f036a20f9ed7d15c4e53283efb12cb355ede/visidata-2.11.tar.gz
BuildArch: noarch
Requires: python3-importlib-metadata
Requires: python3-dateutil
Requires: python3-windows-curses
%description
# VisiData v2.11
[![twitter @VisiData][1.1]][1]
[![Tests](https://github.com/saulpw/visidata/workflows/visidata-ci-build/badge.svg)](https://github.com/saulpw/visidata/actions/workflows/main.yml)
[![Gitpod ready-to-code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/saulpw/visidata)
[![discord](https://img.shields.io/discord/880915750007750737?label=discord)](https://visidata.org/chat)
A terminal interface for exploring and arranging tabular data.
![Frequency table](http://visidata.org/freq-move-row.gif)
VisiData supports tsv, csv, sqlite, json, xlsx (Excel), hdf5, and [many other formats](https://visidata.org/formats).
## Platform requirements
- Linux, OS/X, or Windows (with WSL)
- Python 3.7+
- additional Python modules are required for certain formats and sources
## Install
To install the latest release from PyPi:
pip3 install visidata
To install the cutting edge `develop` branch (no warranty expressed or implied):
pip3 install git+https://github.com/saulpw/visidata.git@develop
See [visidata.org/install](https://visidata.org/install) for detailed instructions for all available platforms and package managers.
### Usage
$ vd
$ | vd
Press `Ctrl+Q` to quit at any time.
Hundreds of other commands and options are also available; see the documentation.
### Documentation
* [VisiData documentation](https://visidata.org/docs)
* [Plugin Author's Guide and API Reference](https://visidata.org/docs/api)
* [Quick reference](https://visidata.org/man) (available within `vd` with `Ctrl+H`), which has a list of commands and options.
* [Intro to VisiData Tutorial](https://jsvine.github.io/intro-to-visidata/) by [Jeremy Singer-Vine](https://www.jsvine.com/)
### Help and Support
If you have a question, issue, or suggestion regarding VisiData, please [create an issue on Github](https://github.com/saulpw/visidata/issues) or chat with us at #visidata on [irc.libera.chat](https://libera.chat/).
If you use VisiData regularly, please [support me on Patreon](https://www.patreon.com/saulpw)!
## License
Code in the `stable` branch of this repository, including the main `vd` application, loaders, and plugins, is available for use and redistribution under GPLv3.
## Credits
VisiData is conceived and developed by Saul Pwanson ``.
Anja Kefala `` maintains the documentation and packages for all platforms.
Many thanks to numerous other [contributors](https://visidata.org/credits/), and to those wonderful users who provide feedback, for helping to make VisiData the awesome tool that it is.
[1.1]: http://i.imgur.com/tXSoThF.png
[1]: http://www.twitter.com/VisiData
%package -n python3-visidata
Summary: terminal interface for exploring and arranging tabular data
Provides: python-visidata
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-visidata
# VisiData v2.11
[![twitter @VisiData][1.1]][1]
[![Tests](https://github.com/saulpw/visidata/workflows/visidata-ci-build/badge.svg)](https://github.com/saulpw/visidata/actions/workflows/main.yml)
[![Gitpod ready-to-code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/saulpw/visidata)
[![discord](https://img.shields.io/discord/880915750007750737?label=discord)](https://visidata.org/chat)
A terminal interface for exploring and arranging tabular data.
![Frequency table](http://visidata.org/freq-move-row.gif)
VisiData supports tsv, csv, sqlite, json, xlsx (Excel), hdf5, and [many other formats](https://visidata.org/formats).
## Platform requirements
- Linux, OS/X, or Windows (with WSL)
- Python 3.7+
- additional Python modules are required for certain formats and sources
## Install
To install the latest release from PyPi:
pip3 install visidata
To install the cutting edge `develop` branch (no warranty expressed or implied):
pip3 install git+https://github.com/saulpw/visidata.git@develop
See [visidata.org/install](https://visidata.org/install) for detailed instructions for all available platforms and package managers.
### Usage
$ vd
$ | vd
Press `Ctrl+Q` to quit at any time.
Hundreds of other commands and options are also available; see the documentation.
### Documentation
* [VisiData documentation](https://visidata.org/docs)
* [Plugin Author's Guide and API Reference](https://visidata.org/docs/api)
* [Quick reference](https://visidata.org/man) (available within `vd` with `Ctrl+H`), which has a list of commands and options.
* [Intro to VisiData Tutorial](https://jsvine.github.io/intro-to-visidata/) by [Jeremy Singer-Vine](https://www.jsvine.com/)
### Help and Support
If you have a question, issue, or suggestion regarding VisiData, please [create an issue on Github](https://github.com/saulpw/visidata/issues) or chat with us at #visidata on [irc.libera.chat](https://libera.chat/).
If you use VisiData regularly, please [support me on Patreon](https://www.patreon.com/saulpw)!
## License
Code in the `stable` branch of this repository, including the main `vd` application, loaders, and plugins, is available for use and redistribution under GPLv3.
## Credits
VisiData is conceived and developed by Saul Pwanson ``.
Anja Kefala `` maintains the documentation and packages for all platforms.
Many thanks to numerous other [contributors](https://visidata.org/credits/), and to those wonderful users who provide feedback, for helping to make VisiData the awesome tool that it is.
[1.1]: http://i.imgur.com/tXSoThF.png
[1]: http://www.twitter.com/VisiData
%package help
Summary: Development documents and examples for visidata
Provides: python3-visidata-doc
%description help
# VisiData v2.11
[![twitter @VisiData][1.1]][1]
[![Tests](https://github.com/saulpw/visidata/workflows/visidata-ci-build/badge.svg)](https://github.com/saulpw/visidata/actions/workflows/main.yml)
[![Gitpod ready-to-code](https://img.shields.io/badge/Gitpod-ready--to--code-blue?logo=gitpod)](https://gitpod.io/#https://github.com/saulpw/visidata)
[![discord](https://img.shields.io/discord/880915750007750737?label=discord)](https://visidata.org/chat)
A terminal interface for exploring and arranging tabular data.
![Frequency table](http://visidata.org/freq-move-row.gif)
VisiData supports tsv, csv, sqlite, json, xlsx (Excel), hdf5, and [many other formats](https://visidata.org/formats).
## Platform requirements
- Linux, OS/X, or Windows (with WSL)
- Python 3.7+
- additional Python modules are required for certain formats and sources
## Install
To install the latest release from PyPi:
pip3 install visidata
To install the cutting edge `develop` branch (no warranty expressed or implied):
pip3 install git+https://github.com/saulpw/visidata.git@develop
See [visidata.org/install](https://visidata.org/install) for detailed instructions for all available platforms and package managers.
### Usage
$ vd
$ | vd
Press `Ctrl+Q` to quit at any time.
Hundreds of other commands and options are also available; see the documentation.
### Documentation
* [VisiData documentation](https://visidata.org/docs)
* [Plugin Author's Guide and API Reference](https://visidata.org/docs/api)
* [Quick reference](https://visidata.org/man) (available within `vd` with `Ctrl+H`), which has a list of commands and options.
* [Intro to VisiData Tutorial](https://jsvine.github.io/intro-to-visidata/) by [Jeremy Singer-Vine](https://www.jsvine.com/)
### Help and Support
If you have a question, issue, or suggestion regarding VisiData, please [create an issue on Github](https://github.com/saulpw/visidata/issues) or chat with us at #visidata on [irc.libera.chat](https://libera.chat/).
If you use VisiData regularly, please [support me on Patreon](https://www.patreon.com/saulpw)!
## License
Code in the `stable` branch of this repository, including the main `vd` application, loaders, and plugins, is available for use and redistribution under GPLv3.
## Credits
VisiData is conceived and developed by Saul Pwanson ``.
Anja Kefala `` maintains the documentation and packages for all platforms.
Many thanks to numerous other [contributors](https://visidata.org/credits/), and to those wonderful users who provide feedback, for helping to make VisiData the awesome tool that it is.
[1.1]: http://i.imgur.com/tXSoThF.png
[1]: http://www.twitter.com/VisiData
%prep
%autosetup -n visidata-2.11
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-visidata -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Thu Mar 09 2023 Python_Bot - 2.11-1
- Package Spec generated