%global _empty_manifest_terminate_build 0
Name:		python-css-parser
Version:	1.0.8
Release:	1
Summary:	A CSS Cascading Style Sheets library for Python
License:	LGPL 3.0 or later
URL:		https://github.com/ebook-utils/css-parser
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a9/01/b78f2b03c9e85fbf96f0f7dc0ddd86e91e21a7dc7b0b7e77166123da6982/css-parser-1.0.8.tar.gz
BuildArch:	noarch


%description
[![Build Status](https://github.com/ebook-utils/css-parser/workflows/CI/badge.svg)](https://github.com/ebook-utils/css-parser/actions?query=workflow%3ACI)
A fork of the cssutils project based on version 1.0.2.
This fork includes general bug fixes and extensions 
specific to editing and working with ebooks.
The main python source code has been modified so
that it will run without further conversion on both 
Python >= 2.7 and Python 3.X without any further
modules required.  All required modifications
are handled local to each file
For more information on usage, please see the 
[cssutils documentation](https://cssutils.readthedocs.io).

%package -n python3-css-parser
Summary:	A CSS Cascading Style Sheets library for Python
Provides:	python-css-parser
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-css-parser
[![Build Status](https://github.com/ebook-utils/css-parser/workflows/CI/badge.svg)](https://github.com/ebook-utils/css-parser/actions?query=workflow%3ACI)
A fork of the cssutils project based on version 1.0.2.
This fork includes general bug fixes and extensions 
specific to editing and working with ebooks.
The main python source code has been modified so
that it will run without further conversion on both 
Python >= 2.7 and Python 3.X without any further
modules required.  All required modifications
are handled local to each file
For more information on usage, please see the 
[cssutils documentation](https://cssutils.readthedocs.io).

%package help
Summary:	Development documents and examples for css-parser
Provides:	python3-css-parser-doc
%description help
[![Build Status](https://github.com/ebook-utils/css-parser/workflows/CI/badge.svg)](https://github.com/ebook-utils/css-parser/actions?query=workflow%3ACI)
A fork of the cssutils project based on version 1.0.2.
This fork includes general bug fixes and extensions 
specific to editing and working with ebooks.
The main python source code has been modified so
that it will run without further conversion on both 
Python >= 2.7 and Python 3.X without any further
modules required.  All required modifications
are handled local to each file
For more information on usage, please see the 
[cssutils documentation](https://cssutils.readthedocs.io).

%prep
%autosetup -n css-parser-1.0.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-css-parser -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.8-1
- Package Spec generated