%global _empty_manifest_terminate_build 0
Name: python-jsonrpcserver
Version: 5.0.9
Release: 1
Summary: Process JSON-RPC requests
License: MIT
URL: https://github.com/explodinglabs/jsonrpcserver
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e3/3b/8d4d4fe8c59a1a4d1e6edd6126ec118b989510fadf262950a5c4f4bca664/jsonrpcserver-5.0.9.tar.gz
BuildArch: noarch
%description
![PyPI](https://img.shields.io/pypi/v/jsonrpcserver.svg)
![Code Quality](https://github.com/explodinglabs/jsonrpcserver/actions/workflows/code-quality.yml/badge.svg)
![Coverage Status](https://coveralls.io/repos/github/explodinglabs/jsonrpcserver/badge.svg?branch=main)
![Downloads](https://img.shields.io/pypi/dw/jsonrpcserver)
Process incoming JSON-RPC requests in Python.
```python
from jsonrpcserver import method, serve, Success
@method
def ping():
return Success("pong")
if __name__ == "__main__":
serve()
```
Or use `dispatch` instead of `serve`:
```python
response = dispatch('{"jsonrpc": "2.0", "method": "ping", "id": 1}')
# => '{"jsonrpc": "2.0", "result": "pong", "id": 1}'
```
[Watch a video on how to use it.](https://www.youtube.com/watch?v=3_BMmgJaFHQ)
Full documentation is at [jsonrpcserver.com](https://www.jsonrpcserver.com/).
See also: [jsonrpcclient](https://github.com/explodinglabs/jsonrpcclient)
%package -n python3-jsonrpcserver
Summary: Process JSON-RPC requests
Provides: python-jsonrpcserver
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jsonrpcserver
![PyPI](https://img.shields.io/pypi/v/jsonrpcserver.svg)
![Code Quality](https://github.com/explodinglabs/jsonrpcserver/actions/workflows/code-quality.yml/badge.svg)
![Coverage Status](https://coveralls.io/repos/github/explodinglabs/jsonrpcserver/badge.svg?branch=main)
![Downloads](https://img.shields.io/pypi/dw/jsonrpcserver)
Process incoming JSON-RPC requests in Python.
```python
from jsonrpcserver import method, serve, Success
@method
def ping():
return Success("pong")
if __name__ == "__main__":
serve()
```
Or use `dispatch` instead of `serve`:
```python
response = dispatch('{"jsonrpc": "2.0", "method": "ping", "id": 1}')
# => '{"jsonrpc": "2.0", "result": "pong", "id": 1}'
```
[Watch a video on how to use it.](https://www.youtube.com/watch?v=3_BMmgJaFHQ)
Full documentation is at [jsonrpcserver.com](https://www.jsonrpcserver.com/).
See also: [jsonrpcclient](https://github.com/explodinglabs/jsonrpcclient)
%package help
Summary: Development documents and examples for jsonrpcserver
Provides: python3-jsonrpcserver-doc
%description help
![PyPI](https://img.shields.io/pypi/v/jsonrpcserver.svg)
![Code Quality](https://github.com/explodinglabs/jsonrpcserver/actions/workflows/code-quality.yml/badge.svg)
![Coverage Status](https://coveralls.io/repos/github/explodinglabs/jsonrpcserver/badge.svg?branch=main)
![Downloads](https://img.shields.io/pypi/dw/jsonrpcserver)
Process incoming JSON-RPC requests in Python.
```python
from jsonrpcserver import method, serve, Success
@method
def ping():
return Success("pong")
if __name__ == "__main__":
serve()
```
Or use `dispatch` instead of `serve`:
```python
response = dispatch('{"jsonrpc": "2.0", "method": "ping", "id": 1}')
# => '{"jsonrpc": "2.0", "result": "pong", "id": 1}'
```
[Watch a video on how to use it.](https://www.youtube.com/watch?v=3_BMmgJaFHQ)
Full documentation is at [jsonrpcserver.com](https://www.jsonrpcserver.com/).
See also: [jsonrpcclient](https://github.com/explodinglabs/jsonrpcclient)
%prep
%autosetup -n jsonrpcserver-5.0.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jsonrpcserver -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 07 2023 Python_Bot - 5.0.9-1
- Package Spec generated