%global _empty_manifest_terminate_build 0
Name:		python-requests_download
Version:	0.1.2
Release:	1
Summary:	Download files using requests and save them to a target path
License:	MIT License
URL:		https://www.github.com/takluyver/requests_download
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/34/9d/431a25538f158a3065a76a6311f40b7908f88a4d24efdbb0ca24f83bd614/requests_download-0.1.2.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
A convenient function to download to a file using requests.

Basic usage:

.. code-block:: python

    url = "https://github.com/takluyver/requests_download/archive/master.zip"
    download(url, "requests_download.zip")

An optional ``headers=`` parameter is passed through to requests.

**Trackers** are a lightweight way to monitor the data being downloaded.
Two trackers are included:

- ``ProgressTracker`` - displays a progress bar, using the `progressbar2
  <https://pypi.python.org/pypi/progressbar2>`_ package.
- ``HashTracker`` - wraps a hashlib object to calculate a hash (e.g. sha256 or
  md5) of the file as you download it.

Here's an example of using both of them:

.. code-block:: python

    import hashlib
    # progressbar is provided by progressbar2 on PYPI.
    from progressbar import DataTransferBar
    from requests_download import download, HashTracker, ProgressTracker

    hasher = HashTracker(hashlib.sha256())
    progress = ProgressTracker(DataTransferBar())

    download('https://github.com/takluyver/requests_download/archive/master.zip',
             'requests_download.zip', trackers=(hasher, progress))

    assert hasher.hashobj.hexdigest() == '...'

To make your own tracker, subclass TrackerBase and define any of these methods:

.. code-block:: python

    from requests_download import TrackerBase

    class MyTracker(TrackerBase):
        def on_start(self, response):
            """Called with requests.Response object, which has response headers"""
            pass

        def on_chunk(self, chunk):
            """Called multiple times, with bytestrings of data received"""
            pass

        def on_finish(self):
            """Called when the download has completed"""
            pass


%package -n python3-requests_download
Summary:	Download files using requests and save them to a target path
Provides:	python-requests_download
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-requests_download
A convenient function to download to a file using requests.

Basic usage:

.. code-block:: python

    url = "https://github.com/takluyver/requests_download/archive/master.zip"
    download(url, "requests_download.zip")

An optional ``headers=`` parameter is passed through to requests.

**Trackers** are a lightweight way to monitor the data being downloaded.
Two trackers are included:

- ``ProgressTracker`` - displays a progress bar, using the `progressbar2
  <https://pypi.python.org/pypi/progressbar2>`_ package.
- ``HashTracker`` - wraps a hashlib object to calculate a hash (e.g. sha256 or
  md5) of the file as you download it.

Here's an example of using both of them:

.. code-block:: python

    import hashlib
    # progressbar is provided by progressbar2 on PYPI.
    from progressbar import DataTransferBar
    from requests_download import download, HashTracker, ProgressTracker

    hasher = HashTracker(hashlib.sha256())
    progress = ProgressTracker(DataTransferBar())

    download('https://github.com/takluyver/requests_download/archive/master.zip',
             'requests_download.zip', trackers=(hasher, progress))

    assert hasher.hashobj.hexdigest() == '...'

To make your own tracker, subclass TrackerBase and define any of these methods:

.. code-block:: python

    from requests_download import TrackerBase

    class MyTracker(TrackerBase):
        def on_start(self, response):
            """Called with requests.Response object, which has response headers"""
            pass

        def on_chunk(self, chunk):
            """Called multiple times, with bytestrings of data received"""
            pass

        def on_finish(self):
            """Called when the download has completed"""
            pass


%package help
Summary:	Development documents and examples for requests_download
Provides:	python3-requests_download-doc
%description help
A convenient function to download to a file using requests.

Basic usage:

.. code-block:: python

    url = "https://github.com/takluyver/requests_download/archive/master.zip"
    download(url, "requests_download.zip")

An optional ``headers=`` parameter is passed through to requests.

**Trackers** are a lightweight way to monitor the data being downloaded.
Two trackers are included:

- ``ProgressTracker`` - displays a progress bar, using the `progressbar2
  <https://pypi.python.org/pypi/progressbar2>`_ package.
- ``HashTracker`` - wraps a hashlib object to calculate a hash (e.g. sha256 or
  md5) of the file as you download it.

Here's an example of using both of them:

.. code-block:: python

    import hashlib
    # progressbar is provided by progressbar2 on PYPI.
    from progressbar import DataTransferBar
    from requests_download import download, HashTracker, ProgressTracker

    hasher = HashTracker(hashlib.sha256())
    progress = ProgressTracker(DataTransferBar())

    download('https://github.com/takluyver/requests_download/archive/master.zip',
             'requests_download.zip', trackers=(hasher, progress))

    assert hasher.hashobj.hexdigest() == '...'

To make your own tracker, subclass TrackerBase and define any of these methods:

.. code-block:: python

    from requests_download import TrackerBase

    class MyTracker(TrackerBase):
        def on_start(self, response):
            """Called with requests.Response object, which has response headers"""
            pass

        def on_chunk(self, chunk):
            """Called multiple times, with bytestrings of data received"""
            pass

        def on_finish(self):
            """Called when the download has completed"""
            pass


%prep
%autosetup -n requests_download-0.1.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-requests_download -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 07 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.2-1
- Package Spec generated