%global _empty_manifest_terminate_build 0
Name:		python-pytest-cov
Version:	4.0.0
Release:	1
Summary:	Pytest plugin for measuring coverage.
License:	MIT
URL:		https://github.com/pytest-dev/pytest-cov
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ea/70/da97fd5f6270c7d2ce07559a19e5bf36a76f0af21500256f005a69d9beba/pytest-cov-4.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-pytest
Requires:	python3-coverage[toml]
Requires:	python3-fields
Requires:	python3-hunter
Requires:	python3-process-tests
Requires:	python3-six
Requires:	python3-pytest-xdist
Requires:	python3-virtualenv

%description


%package -n python3-pytest-cov
Summary:	Pytest plugin for measuring coverage.
Provides:	python-pytest-cov
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-cov


%package help
Summary:	Development documents and examples for pytest-cov
Provides:	python3-pytest-cov-doc
%description help


%prep
%autosetup -n pytest-cov-4.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-cov -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 4.0.0-1
- Package Spec generated