%global _empty_manifest_terminate_build 0
Name: python-murmurhash
Version: 1.0.9
Release: 1
Summary: Cython bindings for MurmurHash
License: MIT
URL: https://github.com/explosion/murmurhash
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f6/24/30e74dc5970f357a897b3ec0fd44e1330c3f5fabefcfa0bc54c80b7ee0a5/murmurhash-1.0.9.tar.gz
%description
# Cython bindings for MurmurHash2
[![Azure Pipelines](https://img.shields.io/azure-devops/build/explosion-ai/public/5/master.svg?logo=azure-pipelines&style=flat-square)](https://dev.azure.com/explosion-ai/public/_build?definitionId=5)
[![pypi Version](https://img.shields.io/pypi/v/murmurhash.svg?style=flat-square&logo=pypi&logoColor=white)](https://pypi.python.org/pypi/murmurhash)
[![conda Version](https://img.shields.io/conda/vn/conda-forge/murmurhash.svg?style=flat-square&logo=conda-forge&logoColor=white)](https://anaconda.org/conda-forge/murmurhash)
[![Python wheels](https://img.shields.io/badge/wheels-%E2%9C%93-4c1.svg?longCache=true&style=flat-square&logo=python&logoColor=white)](https://github.com/explosion/wheelwright/releases)
%package -n python3-murmurhash
Summary: Cython bindings for MurmurHash
Provides: python-murmurhash
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-murmurhash
# Cython bindings for MurmurHash2
[![Azure Pipelines](https://img.shields.io/azure-devops/build/explosion-ai/public/5/master.svg?logo=azure-pipelines&style=flat-square)](https://dev.azure.com/explosion-ai/public/_build?definitionId=5)
[![pypi Version](https://img.shields.io/pypi/v/murmurhash.svg?style=flat-square&logo=pypi&logoColor=white)](https://pypi.python.org/pypi/murmurhash)
[![conda Version](https://img.shields.io/conda/vn/conda-forge/murmurhash.svg?style=flat-square&logo=conda-forge&logoColor=white)](https://anaconda.org/conda-forge/murmurhash)
[![Python wheels](https://img.shields.io/badge/wheels-%E2%9C%93-4c1.svg?longCache=true&style=flat-square&logo=python&logoColor=white)](https://github.com/explosion/wheelwright/releases)
%package help
Summary: Development documents and examples for murmurhash
Provides: python3-murmurhash-doc
%description help
# Cython bindings for MurmurHash2
[![Azure Pipelines](https://img.shields.io/azure-devops/build/explosion-ai/public/5/master.svg?logo=azure-pipelines&style=flat-square)](https://dev.azure.com/explosion-ai/public/_build?definitionId=5)
[![pypi Version](https://img.shields.io/pypi/v/murmurhash.svg?style=flat-square&logo=pypi&logoColor=white)](https://pypi.python.org/pypi/murmurhash)
[![conda Version](https://img.shields.io/conda/vn/conda-forge/murmurhash.svg?style=flat-square&logo=conda-forge&logoColor=white)](https://anaconda.org/conda-forge/murmurhash)
[![Python wheels](https://img.shields.io/badge/wheels-%E2%9C%93-4c1.svg?longCache=true&style=flat-square&logo=python&logoColor=white)](https://github.com/explosion/wheelwright/releases)
%prep
%autosetup -n murmurhash-1.0.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-murmurhash -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 1.0.9-1
- Package Spec generated