%global _empty_manifest_terminate_build 0
Name:		python-connexion
Version:	2.14.2
Release:	1
Summary:	Connexion - API first applications with OpenAPI/Swagger and Flask
License:	Apache License Version 2.0
URL:		https://github.com/zalando/connexion
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8f/8b/c1d8a2e9327787354e936184f424b1ae96e526a0dad031bbc218c9dcaf35/connexion-2.14.2.tar.gz
BuildArch:	noarch

Requires:	python3-clickclick
Requires:	python3-jsonschema
Requires:	python3-PyYAML
Requires:	python3-requests
Requires:	python3-inflection
Requires:	python3-werkzeug
Requires:	python3-packaging
Requires:	python3-flask
Requires:	python3-itsdangerous
Requires:	python3-importlib-metadata
Requires:	python3-aiohttp
Requires:	python3-aiohttp-jinja2
Requires:	python3-MarkupSafe
Requires:	python3-sphinx-autoapi
Requires:	python3-flask
Requires:	python3-itsdangerous
Requires:	python3-swagger-ui-bundle
Requires:	python3-decorator
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-testfixtures
Requires:	python3-flask
Requires:	python3-itsdangerous
Requires:	python3-swagger-ui-bundle
Requires:	python3-aiohttp
Requires:	python3-aiohttp-jinja2
Requires:	python3-MarkupSafe
Requires:	python3-pytest-aiohttp
Requires:	python3-aiohttp-remotes

%description
Connexion is a framework that automagically handles HTTP requests based on `OpenAPI Specification`_
(formerly known as Swagger Spec) of your API described in `YAML format`_. Connexion allows you to
write an OpenAPI specification, then maps the endpoints to your Python functions; this makes it
unique, as many tools generate the specification based on your Python code. You can describe your
REST API in as much detail as you want; then Connexion guarantees that it will work as you
specified.
We built Connexion this way in order to:
- simplify the development process
- confirm expectations about what your API will look like

%package -n python3-connexion
Summary:	Connexion - API first applications with OpenAPI/Swagger and Flask
Provides:	python-connexion
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-connexion
Connexion is a framework that automagically handles HTTP requests based on `OpenAPI Specification`_
(formerly known as Swagger Spec) of your API described in `YAML format`_. Connexion allows you to
write an OpenAPI specification, then maps the endpoints to your Python functions; this makes it
unique, as many tools generate the specification based on your Python code. You can describe your
REST API in as much detail as you want; then Connexion guarantees that it will work as you
specified.
We built Connexion this way in order to:
- simplify the development process
- confirm expectations about what your API will look like

%package help
Summary:	Development documents and examples for connexion
Provides:	python3-connexion-doc
%description help
Connexion is a framework that automagically handles HTTP requests based on `OpenAPI Specification`_
(formerly known as Swagger Spec) of your API described in `YAML format`_. Connexion allows you to
write an OpenAPI specification, then maps the endpoints to your Python functions; this makes it
unique, as many tools generate the specification based on your Python code. You can describe your
REST API in as much detail as you want; then Connexion guarantees that it will work as you
specified.
We built Connexion this way in order to:
- simplify the development process
- confirm expectations about what your API will look like

%prep
%autosetup -n connexion-2.14.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-connexion -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.14.2-1
- Package Spec generated