%global _empty_manifest_terminate_build 0
Name:		python-WebTest
Version:	3.0.0
Release:	1
Summary:	Helper to test WSGI applications
License:	MIT
URL:		https://docs.pylonsproject.org/projects/webtest/en/latest/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/26/c8/8ffba1782700eb06e9b9169156698c6ba95c05b66cda3fc9e025b6b3b649/WebTest-3.0.0.tar.gz
BuildArch:	noarch

Requires:	python3-WebOb
Requires:	python3-waitress
Requires:	python3-beautifulsoup4
Requires:	python3-docutils
Requires:	python3-pylons-sphinx-themes
Requires:	python3-Sphinx
Requires:	python3-coverage
Requires:	python3-PasteDeploy
Requires:	python3-pyquery
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-WSGIProxy2

%description


%package -n python3-WebTest
Summary:	Helper to test WSGI applications
Provides:	python-WebTest
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-WebTest


%package help
Summary:	Development documents and examples for WebTest
Provides:	python3-WebTest-doc
%description help


%prep
%autosetup -n WebTest-3.0.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-WebTest -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
- Package Spec generated