%global _empty_manifest_terminate_build 0
Name: python-h3
Version: 3.7.6
Release: 1
Summary: Hierarchical hexagonal geospatial indexing system
License: Apache 2.0 License
URL: https://github.com/uber/h3-py
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0e/92/30070479f7c41d66dc5f0ac44298eaedf4a7dad722348dac82d6dcc7ddd8/h3-3.7.6.tar.gz
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-flake8
Requires: python3-pylint
Requires: python3-numpy
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-flake8
Requires: python3-pylint
%description
# **h3-py**: Uber's H3 Hexagonal Hierarchical Geospatial Indexing System in Python
[](https://badge.fury.io/py/h3)
[](https://pypistats.org/packages/h3)
[](https://anaconda.org/conda-forge/h3-py)
[](https://github.com/uber/h3/releases/tag/v3.7.1)
[](https://github.com/uber/h3-py/blob/master/LICENSE)
[](https://github.com/uber/h3-py/actions)
[](https://codecov.io/gh/uber/h3-py)
Python bindings for the [H3 core library](https://h3geo.org/).
- Documentation: [uber.github.io/h3-py](https://uber.github.io/h3-py)
- GitHub repo: [github.com/uber/h3-py](https://github.com/uber/h3-py)
## Installation
From [PyPI](https://pypi.org/project/h3/):
```console
pip install h3
```
From [conda](https://github.com/conda-forge/h3-py-feedstock):
```console
conda config --add channels conda-forge
conda install h3-py
```
## Usage
```python
>>> import h3
>>> lat, lng = 37.769377, -122.388903
>>> resolution = 9
>>> h3.geo_to_h3(lat, lng, resolution)
'89283082e73ffff'
```
## APIs
[api_comparison]: https://uber.github.io/h3-py/api_comparison
[api_reference]: https://uber.github.io/h3-py/api_reference
We provide [multiple APIs][api_comparison] in `h3-py`.
- All APIs have the same set of functions;
see the [API reference][api_reference].
- The APIs differ only in their input/output formats;
see the [API comparison page][api_comparison].
## Example gallery
Browse [a collection of example notebooks](https://github.com/uber/h3-py-notebooks),
and if you have examples or visualizations of your own, please feel free
to contribute!
[walkthrough]: https://nbviewer.jupyter.org/github/uber/h3-py-notebooks/blob/master/notebooks/usage.ipynb
We also have an introductory [walkthrough of the API][walkthrough].
## Versioning
`h3-py` wraps the [H3 core library](https://github.com/uber/h3),
which is written in C.
The C and Python projects each employ
[semantic versioning](https://semver.org/),
where versions take the form `X.Y.Z`.
The `h3-py` version string is guaranteed to match the C library string
in both *major* and *minor* numbers (`X.Y`), but may differ on the
*patch* (`Z`) number.
This convention provides users with information on breaking changes and
feature additions, while providing downstream bindings (like this one!)
with the versioning freedom to fix bugs.
Use `h3.versions()` to see the version numbers for both
`h3-py` and the C library. For example,
```python
>>> import h3
>>> h3.versions()
{'c': '3.6.3', 'python': '3.6.1'}
```
%package -n python3-h3
Summary: Hierarchical hexagonal geospatial indexing system
Provides: python-h3
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-h3
# **h3-py**: Uber's H3 Hexagonal Hierarchical Geospatial Indexing System in Python
[](https://badge.fury.io/py/h3)
[](https://pypistats.org/packages/h3)
[](https://anaconda.org/conda-forge/h3-py)
[](https://github.com/uber/h3/releases/tag/v3.7.1)
[](https://github.com/uber/h3-py/blob/master/LICENSE)
[](https://github.com/uber/h3-py/actions)
[](https://codecov.io/gh/uber/h3-py)
Python bindings for the [H3 core library](https://h3geo.org/).
- Documentation: [uber.github.io/h3-py](https://uber.github.io/h3-py)
- GitHub repo: [github.com/uber/h3-py](https://github.com/uber/h3-py)
## Installation
From [PyPI](https://pypi.org/project/h3/):
```console
pip install h3
```
From [conda](https://github.com/conda-forge/h3-py-feedstock):
```console
conda config --add channels conda-forge
conda install h3-py
```
## Usage
```python
>>> import h3
>>> lat, lng = 37.769377, -122.388903
>>> resolution = 9
>>> h3.geo_to_h3(lat, lng, resolution)
'89283082e73ffff'
```
## APIs
[api_comparison]: https://uber.github.io/h3-py/api_comparison
[api_reference]: https://uber.github.io/h3-py/api_reference
We provide [multiple APIs][api_comparison] in `h3-py`.
- All APIs have the same set of functions;
see the [API reference][api_reference].
- The APIs differ only in their input/output formats;
see the [API comparison page][api_comparison].
## Example gallery
Browse [a collection of example notebooks](https://github.com/uber/h3-py-notebooks),
and if you have examples or visualizations of your own, please feel free
to contribute!
[walkthrough]: https://nbviewer.jupyter.org/github/uber/h3-py-notebooks/blob/master/notebooks/usage.ipynb
We also have an introductory [walkthrough of the API][walkthrough].
## Versioning
`h3-py` wraps the [H3 core library](https://github.com/uber/h3),
which is written in C.
The C and Python projects each employ
[semantic versioning](https://semver.org/),
where versions take the form `X.Y.Z`.
The `h3-py` version string is guaranteed to match the C library string
in both *major* and *minor* numbers (`X.Y`), but may differ on the
*patch* (`Z`) number.
This convention provides users with information on breaking changes and
feature additions, while providing downstream bindings (like this one!)
with the versioning freedom to fix bugs.
Use `h3.versions()` to see the version numbers for both
`h3-py` and the C library. For example,
```python
>>> import h3
>>> h3.versions()
{'c': '3.6.3', 'python': '3.6.1'}
```
%package help
Summary: Development documents and examples for h3
Provides: python3-h3-doc
%description help
# **h3-py**: Uber's H3 Hexagonal Hierarchical Geospatial Indexing System in Python
[](https://badge.fury.io/py/h3)
[](https://pypistats.org/packages/h3)
[](https://anaconda.org/conda-forge/h3-py)
[](https://github.com/uber/h3/releases/tag/v3.7.1)
[](https://github.com/uber/h3-py/blob/master/LICENSE)
[](https://github.com/uber/h3-py/actions)
[](https://codecov.io/gh/uber/h3-py)
Python bindings for the [H3 core library](https://h3geo.org/).
- Documentation: [uber.github.io/h3-py](https://uber.github.io/h3-py)
- GitHub repo: [github.com/uber/h3-py](https://github.com/uber/h3-py)
## Installation
From [PyPI](https://pypi.org/project/h3/):
```console
pip install h3
```
From [conda](https://github.com/conda-forge/h3-py-feedstock):
```console
conda config --add channels conda-forge
conda install h3-py
```
## Usage
```python
>>> import h3
>>> lat, lng = 37.769377, -122.388903
>>> resolution = 9
>>> h3.geo_to_h3(lat, lng, resolution)
'89283082e73ffff'
```
## APIs
[api_comparison]: https://uber.github.io/h3-py/api_comparison
[api_reference]: https://uber.github.io/h3-py/api_reference
We provide [multiple APIs][api_comparison] in `h3-py`.
- All APIs have the same set of functions;
see the [API reference][api_reference].
- The APIs differ only in their input/output formats;
see the [API comparison page][api_comparison].
## Example gallery
Browse [a collection of example notebooks](https://github.com/uber/h3-py-notebooks),
and if you have examples or visualizations of your own, please feel free
to contribute!
[walkthrough]: https://nbviewer.jupyter.org/github/uber/h3-py-notebooks/blob/master/notebooks/usage.ipynb
We also have an introductory [walkthrough of the API][walkthrough].
## Versioning
`h3-py` wraps the [H3 core library](https://github.com/uber/h3),
which is written in C.
The C and Python projects each employ
[semantic versioning](https://semver.org/),
where versions take the form `X.Y.Z`.
The `h3-py` version string is guaranteed to match the C library string
in both *major* and *minor* numbers (`X.Y`), but may differ on the
*patch* (`Z`) number.
This convention provides users with information on breaking changes and
feature additions, while providing downstream bindings (like this one!)
with the versioning freedom to fix bugs.
Use `h3.versions()` to see the version numbers for both
`h3-py` and the C library. For example,
```python
>>> import h3
>>> h3.versions()
{'c': '3.6.3', 'python': '3.6.1'}
```
%prep
%autosetup -n h3-3.7.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-h3 -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 3.7.6-1
- Package Spec generated