%global _empty_manifest_terminate_build 0
Name: python-fasttext
Version: 0.9.2
Release: 1
Summary: fasttext Python bindings
License: MIT
URL: https://github.com/facebookresearch/fastText
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f8/85/e2b368ab6d3528827b147fdb814f8189acc981a4bc2f99ab894650e05c40/fasttext-0.9.2.tar.gz
BuildArch: noarch
%description
`fastText `__ is a library for efficient learning
of word representations and sentence classification.
In this document we present how to use fastText in python.
%package -n python3-fasttext
Summary: fasttext Python bindings
Provides: python-fasttext
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-fasttext
`fastText `__ is a library for efficient learning
of word representations and sentence classification.
In this document we present how to use fastText in python.
%package help
Summary: Development documents and examples for fasttext
Provides: python3-fasttext-doc
%description help
`fastText `__ is a library for efficient learning
of word representations and sentence classification.
In this document we present how to use fastText in python.
%prep
%autosetup -n fasttext-0.9.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-fasttext -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 0.9.2-1
- Package Spec generated