%global _empty_manifest_terminate_build 0
Name: python-SpeechRecognition
Version: 3.10.0
Release: 1
Summary: Library for performing speech recognition, with support for several engines and APIs, online and offline.
License: BSD
URL: https://github.com/Uberi/speech_recognition#readme
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/65/1307adaf5f29d850fc0925251f71bb5aa3d030043ac8a373e7ae6982bf29/SpeechRecognition-3.10.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-openai
%description
Library for performing speech recognition, with support for several engines and APIs, online and offline.
**UPDATE 2022-02-09**: Hey everyone! This project started as a tech demo, but these days it needs more time than I have to keep up with all the PRs and issues. Therefore, I'd like to put out an **open invite for collaborators** - just reach out at me@anthonyz.ca if you're interested!
Speech recognition engine/API support:
* `CMU Sphinx `__ (works offline)
* Google Speech Recognition
* `Google Cloud Speech API `__
* `Wit.ai `__
* `Microsoft Azure Speech `__
* `Microsoft Bing Voice Recognition (Deprecated) `__
* `Houndify API `__
* `IBM Speech to Text `__
* `Snowboy Hotword Detection `__ (works offline)
* `Tensorflow `__
* `Vosk API `__ (works offline)
* `OpenAI whisper `__ (works offline)
* `Whisper API `__
**Quickstart:** ``pip install SpeechRecognition``. See the "Installing" section for more details.
To quickly try it out, run ``python -m speech_recognition`` after installing.
Project links:
- `PyPI `__
- `Source code `__
- `Issue tracker `__
%package -n python3-SpeechRecognition
Summary: Library for performing speech recognition, with support for several engines and APIs, online and offline.
Provides: python-SpeechRecognition
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-SpeechRecognition
Library for performing speech recognition, with support for several engines and APIs, online and offline.
**UPDATE 2022-02-09**: Hey everyone! This project started as a tech demo, but these days it needs more time than I have to keep up with all the PRs and issues. Therefore, I'd like to put out an **open invite for collaborators** - just reach out at me@anthonyz.ca if you're interested!
Speech recognition engine/API support:
* `CMU Sphinx `__ (works offline)
* Google Speech Recognition
* `Google Cloud Speech API `__
* `Wit.ai `__
* `Microsoft Azure Speech `__
* `Microsoft Bing Voice Recognition (Deprecated) `__
* `Houndify API `__
* `IBM Speech to Text `__
* `Snowboy Hotword Detection `__ (works offline)
* `Tensorflow `__
* `Vosk API `__ (works offline)
* `OpenAI whisper `__ (works offline)
* `Whisper API `__
**Quickstart:** ``pip install SpeechRecognition``. See the "Installing" section for more details.
To quickly try it out, run ``python -m speech_recognition`` after installing.
Project links:
- `PyPI `__
- `Source code `__
- `Issue tracker `__
%package help
Summary: Development documents and examples for SpeechRecognition
Provides: python3-SpeechRecognition-doc
%description help
Library for performing speech recognition, with support for several engines and APIs, online and offline.
**UPDATE 2022-02-09**: Hey everyone! This project started as a tech demo, but these days it needs more time than I have to keep up with all the PRs and issues. Therefore, I'd like to put out an **open invite for collaborators** - just reach out at me@anthonyz.ca if you're interested!
Speech recognition engine/API support:
* `CMU Sphinx `__ (works offline)
* Google Speech Recognition
* `Google Cloud Speech API `__
* `Wit.ai `__
* `Microsoft Azure Speech `__
* `Microsoft Bing Voice Recognition (Deprecated) `__
* `Houndify API `__
* `IBM Speech to Text `__
* `Snowboy Hotword Detection `__ (works offline)
* `Tensorflow `__
* `Vosk API `__ (works offline)
* `OpenAI whisper `__ (works offline)
* `Whisper API `__
**Quickstart:** ``pip install SpeechRecognition``. See the "Installing" section for more details.
To quickly try it out, run ``python -m speech_recognition`` after installing.
Project links:
- `PyPI `__
- `Source code `__
- `Issue tracker `__
%prep
%autosetup -n SpeechRecognition-3.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-SpeechRecognition -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Mon Apr 10 2023 Python_Bot - 3.10.0-1
- Package Spec generated